HDU 5391 Zball in Tina Town

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 726    Accepted Submission(s): 417


Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become 2 times as large as the size on the first day. On the n-th day,it will become n times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
 

Input
The first line of input contains an integer T , representing the number of cases.

The following T lines, each line contains an integer n , according to the description.
T105,2n109
 

Output
For each test case, output an integer representing the answer.
 

Sample Input
  
  
2 3 10
 

Sample Output
  
  
2 0
 

Source


这题很容易可以判断出,如果这个数不是素数,那么答案就是0(除了4)
4比较特殊,因为判断是不是素数的时候,2*2.而在这题里面,分母只有一个2.

接下来就是要处理素数的情况。如果直接计算取模,会超时。

引入数学知识:

威尔逊定理。
初等数论中,威尔逊定理给出了判定一个自然数是否为素数充分必要条件。即:当且仅当p为素数时:( p -1 )! ≡ p-1 ( mod p )
#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <functional>
#include <numeric>
#include <sstream>
#include <stack>
#include <map>
#include <queue>
#define ll long long
using namespace std;
bool is(int k,int f)
{
    
    for(int i=2;i<f;i++)
    {
        if(i*i==k)return 1;
        if(k%i==0)return 0;
	}
    return 1;
}
int main()
{
    int T;
    scanf("%ld",&T);
    while(T--)
    {
        int n;
        scanf("%ld",&n);
        int f = ceil(sqrt(n)+1);
        if(is(n,f))
        {
        	if(n==4)printf("%ld\n",n-2);
        	else
            printf("%ld\n",n-1);
        }
        else
        printf("0\n");
    } 
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值