HDU2104 hide handkerchief

Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me “YES”, else tell me “POOR Haha”.

Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.

Output
For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input
3 2
-1 -1

Sample Output
YES

Source
HDU 2007-6 Programming Contest

Recommend
xhd | We have carefully selected several similar problems for you: 2103 2106 2100 2102 2105

康复训练第四题
题意:几个小朋友坐成一圈,面前都有一个盒子,只有一个盒子里面可能有东西,haha从起点开始找,数到M个就开一个盒子,绕着圈继续数,继续开。如果她肯定能找到就输出YES
思路:一开始WA了是以为只需要输入的N和M判断一下取余是否为0,如果能除尽就说明每个位子都能打开。实际上正确思路是看两个数是否互质,因为找到最后,打开的两个盒子之间相差N和M的最大公约数的距离,也就是如果最大公约数是1,就是每个盒子都能打开了。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int gcd(int a, int b){ return a == 0 ? b : gcd(b % a, a); } 
int main()
{
    int a,b;
    while(cin >> a >> b)
    {
    if(a==-1&&b==-1)break;
    if(gcd(a,b)==1)cout<<"YES"<<endl;
    else cout<<"POOR Haha"<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值