hdu 4565 So Easy!


Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy! 
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 

Output
  For each the case, output an integer S n.
 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
  
  
4 14
4
题目分析:

题目要求这个得值

但是取模前有更号,所以无法直接计算,我们发现

0< a, m < 215, (a-1)2< b < a2, 0 < b, n < 231

所以 0 <a+sqrt( b ) < 1

可得表达式:,由二项式展开可知等号右边一坨是整数并且加的数小于一,所以等式成立

然后我们设 Kn 为为等号的左边,将表达式化为递推形式后,再利用矩阵连乘来解决 Kn 的问题

转化过程就是移两次项,每次都将指数约去即可化简

# include<iostream>
# include<cstdio>
# include<cstring>
typedef __int64 ll;
using namespace std;
ll n,m,a,b;
struct node
{
   ll x[2][2];
} op;
node cheng(node a,node b)
{
    node t;
    int i,j,k;
    for (i=0;i<2;i++)
    for (j=0;j<2;j++)
    {
        ll sum=0;
        for (k=0;k<2;k++)
        sum=(sum+(ll)a.x[i][k]*b.x[k][j])%m;
        t.x[i][j]=sum;
    }
    return t;
}
int main()
{
    while (~scanf("%I64d%I64d%I64d%I64d",&a,&b,&n,&m))
    {
        ll x,y;
        x=(2*a)%m; y=(2*(a*a+b))%m;
        op.x[0][0]=(2*a)%m; op.x[0][1]=1;
        op.x[1][0]=((b-a*a%m)+m)%m;//不要掉了这里的+m 
        op.x[1][1]=0;
        if (n==1) { printf("%I64d\n",x); continue;};
        if (n==2) { printf("%I64d\n",y); continue;};
        node ans;
        ans=op;
        n=n-3;
        while (n)
        {
            if (n&1) op=cheng(op,ans);
            ans=cheng(ans,ans);
            n=n/2;
        }
        printf("%I64d\n",(op.x[0][0]*y+op.x[1][0]*x)%m);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值