Knight Moves UVA439



 Knight Moves 

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


这道题题目一看觉得很简单,但是看了样例数据之后发现不对劲,在网上搜了好久才发现国际象棋马的走法是这样走的,走日字。

为此打印了几张国际象棋的棋盘格局,后来就理解了,简单的bfs,不过bfs对我来说还是有点生疏。

#include<iostream>
#include<cstring>
#include<queue>
#include<string>

using namespace std;

int dist[10][10];
int grid[10][10];
int dx[8]={1,2,2,1,-1,-2,-2,-1};
int dy[8]={-2,-1,1,2,2,1,-1,-2};
queue<int> team;

void bfs(int x,int y)
{
    int u=8*x+y;
    grid[x][y]=1;
    dist[x][y]=0;
    team.push(u);
    while(!team.empty())
    {
        u=team.front();
        x=u/8,y=u%8;
        team.pop();
        for(int i=0;i<8;i++)
        {
            int nx,ny;
            nx=x+dx[i];
            ny=y+dy[i];
            if(nx>=0&&nx<8&&ny>=0&&ny<8&&!grid[nx][ny])
            {
                int v=8*nx+ny;
                team.push(v);
                grid[nx][ny]=1;
                dist[nx][ny]=dist[x][y]+1;
            }
        }
    }
}

int main()
{
    string str1,str2;
    while(cin>>str1>>str2)
    {
        while(!team.empty())
            team.pop();
        memset(grid,0,sizeof(grid));
        memset(dist,0,sizeof(dist));
        int x1,y1,x2,y2;
        x1=str1[0]-'a';
        y1=str1[1]-'1';
        x2=str2[0]-'a';
        y2=str2[1]-'1';
        bfs(x1,y1);
        cout<<"To get from "<<str1<< " to "<<str2<<" takes "<<dist[x2][y2]<<" knight moves."<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值