[隐式图搜索]Knights in FEN UVA10422

Problem D

Knights in FEN

Input: standard input

Output: standard output

Time Limit: 10 seconds

 

There are black and white knights on a 5 by 5 chessboard. There are twelve of each color, and there is one square that is empty. At any time, a knight can move into an empty square as long as it moves like a knight in normal chess (what else did you expect?).

Given an initial position of the board, the question is: what is the minimum number of moves in which we can reach the final position which is:

Input

First line of the input file contains an integer N (N<14) that indicates how many sets of inputs are there. The description of each set is given below:

Each set consists of five lines; each line represents one row of a chessboard. The positions occupied by white knights are marked by 0 and the positions occupied by black knights are marked by 1. The space corresponds to the empty square on board.

There is no blank line between the two sets of input.

The first set of the sample input below corresponds to this configuration:

Output

For each set your task is to find the minimum number of moves leading from the starting input configuration to the final one. If that number is bigger than 10, then output one line stating

Unsolvable in less than 11 move(s).

 

otherwise output one line stating

Solvable in n move(s).

where n <= 10.

The output for each set is produced in a single line as shown in the sample output.

Sample Input

2
01011
110 1
01110
01010
00100
10110
01 11
10111
01001
00000

Sample Output

Unsolvable in less than 11 move(s).
Solvable in 7 move(s).

(Problem Setter: Piotr Rudnicki, University of Alberta, Canada)

 

 

A man is as great as his dreams.”

 

 


题意:给出一个状态图,移动其中的骑士恢复到初始的状态。

典型的隐式图搜索问题,BFS搜索+哈希,哈希我是用的set实现的,另外要注意的是国际象棋中骑士走的是日字。

#include<iostream>
#include<cstring>
#include<string>
#include<set>

using namespace std;

typedef int state[25];
const int maxn=5000000;
const int dx[]={1,2,2,1,-1,-2,-2,-1};
const int dy[]={-2,-1,1,2,2,1,-1,-2};
state st[maxn];
int dist[maxn];
int front,rear,s;
set<int> vis;
state goal={1,1,1,1,1,0,1,1,1,1,0,0,2,1,1,0,0,0,0,1,0,0,0,0,0};

int try_to_insert(int s)//哈希函数
{
    int v=0;
    for(int i=0;i<25;i++) v=v*2+st[s][i];
    if(vis.count(v))return 0;
    vis.insert(v);
    return 1;
}

int bfs()
{
    front=1,rear=2;
    vis.clear();
    while(front<rear)
    {
        state &p=st[front];
        if(dist[front]>10) return -1;//剪枝,超过10步认为不可达
        if(memcmp(goal,p,sizeof(p))==0) return front;
        int i,j,x,y;
        for(i=0;i<25;i++) if(st[front][i]==2) break;
        int z=i;
        x=i/5,y=i%5;
        for(i=0;i<8;i++)
        {
            int newx=x+dx[i];
            int newy=y+dy[i];
            if(newx>=0&&newx<5&&newy>=0&&newy<5)
            {
                state &u=st[rear];
                memcpy(&u,&p,sizeof(p));
                u[x*5+y]=u[newx*5+newy];
                u[newx*5+newy]=2;
                dist[rear]=dist[front]+1;
                if(try_to_insert(rear)) rear++;
            }
        }
        front++;
    }
}

int main()
{
    cin>>s;
    string str;
    getline(cin,str);
    while(s--)
    {
        memset(dist,0,sizeof(dist));
        int i,j;
        for(i=0;i<5;i++)
        {
            getline(cin,str);
            for(j=0;j<5;j++)
            {
                if(str[j]!=' ') st[1][i*5+j]=str[j]-'0';
                else st[1][i*5+j]=2;
            }
        }
        int d=bfs();
        if(d<=0) cout<<"Unsolvable in less than 11 move(s)."<<endl;
        else cout<<"Solvable in "<<dist[d]<<" move(s)."<<endl;
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值