[模拟水题&&中位数]uva10041 Vito's Family



  Problem C: Vito's family 

Background 

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.

Problem 

Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

Input 

The input consists of several test cases. The first line contains the number of test cases.

For each test case you will be given the integer number of relatives r ( 0 < r < 500) and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$ where they live ( 0 < si < 30000 ). Note that several relatives could live in the same street number.

Output 

For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers  s i  and  s j  is  d ij = | s i - s j |.

Sample Input 

2
2 2 4 
3 2 4 6

Sample Output 

2
4



Miguel Revilla 
2000-11-19

题意:世界闻名的黑社会老大Vito Deadstone要搬到纽约来了。在那里他有一个大家族,并且他们都住在Lamafia大道上。因为Vito时常要拜访所有的亲戚,他想要找一间离他们最近的房子,也就是说他希望从他的家到所有的亲戚的家的距离的和为最小。

他恐吓你写一个程式来帮助帮助他解决这个问题。

思路:看清楚题目之后就很好理解了,就是典型的中位数。

#include<iostream>
#include<algorithm>

using namespace std;

int arry[550];

int main()
{
    int n,m;
    cin>>n;
    while(n--)
    {
        cin>>m;
        for(int i=0;i<m;i++)
            cin>>arry[i];
        sort(arry,arry+m);
        int pos=(m-1)/2;
        int sum=0;
        for(int i=0;i<m;i++)
        {
            if(arry[i]-arry[pos]<=0) sum=sum+(-1)*(arry[i]-arry[pos]);
            else sum=sum+arry[i]-arry[pos];
        }
        cout<<sum<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值