[动态规划]UVA147 - Dollars


 Dollars 

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 tex2html_wrap_inline25 20c, 2 tex2html_wrap_inline25 10c, 10c+2 tex2html_wrap_inline25 5c, and 4 tex2html_wrap_inline25 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4
  2.00              293

题意:

纽西兰的货币包含了$100, $50, $20, $10, $5 的纸钞和$2, $1, 50c, 20c, 10c, 5c 的硬币。给你某金额的数字,请你写一个程式回答:使用这些面额的​​纸钞或硬币,有多少种不同的方法可以组合成这个金额。例如:20c 可以有4个方法可以得到:(改变金额的顺序不会增加方法数,例如2 * 5c + 1 * 10c 和下面第3种方法视为同一种)

  • 1 * 20c
  • 2 * 10c
  • 1* 10c + 2 * 5c
  • 4 * 5c
思路:硬币转转,典型的DP题目。输入有点坑爹,用double精度貌似出问题,所以用两个整数来替换。
#include<iostream>
#include<cstring>
#include<iomanip>

using namespace std;

const int maxn=30100;
int d[12]={0,10000,5000,2000,1000,500,200,100,50,20,10,5};
long long dp[maxn];

int main()
    {
        int x,y;
        char ch;
        while(cin>>x>>ch>>y)
            {
                int val=x*100+y;
                if(val==0) break;
                memset(dp,0,sizeof(dp));
                dp[0]=1;
                int i,j,k;
                for(i=1;i<=11;i++)
                    {
                        for(j=d[i];j<=val;j++)
                            {
                                dp[j]=dp[j]+dp[j-d[i]];
                            }
                    }
                double dval=val/100.0;
                cout<<setiosflags(ios::right)<<setw(6)<<fixed<<setprecision(2)<<dval;
                cout<<setiosflags(ios::right)<<setw(17)<<dp[val]<<endl;
            }
        return 0;
    }


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值