UVA 10099 - The Tourist Guide(floyd)

Problem D

The Tourist Guide

Input: standard input

Output: standard output

 

Mr. G. works as a tourist guide. His current assignment is to take some tourists from one city to another. Some two-way roads connect the cities. For each pair of neighboring cities there is a bus service that runs only between those two cities and uses the road that directly connects them. Each bus service has a limit on the maximum number of passengers it can carry. Mr. G. has a map showing the cities and the roads connecting them. He also has the information regarding each bus service. He understands that it may not always be possible for him to take all the tourists to the destination city in a single trip. For example, consider the following road map of 7 cities. The edges connecting the cities represent the roads and the number written on each edge indicates the passenger limit of the bus service that runs on that road.

 

                           

Now, if he wants to take 99 tourists from city 1 to city 7, he will require at least 5 trips, since he has to ride the bus with each group, and the route he should take is : 1 - 2 - 4 - 7.

But, Mr. G. finds it difficult to find the best route all by himself so that he may be able to take all the tourists to the destination city in minimum number of trips. So, he seeks your help.

 

Input

The input will contain one or more test cases. The first line of each test case will contain two integers: N (N<= 100) and R representing respectively the number of cities and the number of road segments. Then R lines will follow each containing three integers: C1C2 and PC1 andC2 are the city numbers and P (P> 1) is the limit on the maximum number of passengers to be carried by the bus service between the two cities. City numbers are positive integers ranging from 1 to N. The (R + 1)-th line will contain three integers: SD and T representing respectively the starting city, the destination city and the number of tourists to be guided.

The input will end with two zeroes for N and R.

 

Output

For each test case in the input first output the scenario number. Then output the minimum number of trips required for this case on a separate line. Print a blank line after the output of each test case.

 

Sample Input

7 10
1 2 30
1 3 15
1 4 10
2 4 25
2 5 60
3 4 40
3 6 20
4 7 35
5 7 20
6 7 30
1 7 99
0 0

Sample Output

Scenario #1
Minimum Number of Trips = 5

题意:n个点,m条路径,每条路径最多通过人数最多为value人,求把v个游客从a点运送到b点,需要几辆车,注意导游自己也算一个人。

思路:floyd找出两点间最大运送量,然后计算需要几躺即可

代码:

#include <stdio.h>
#include <string.h>

int n, m, i, j, k, map[105][105];
int a, b, value;
int min(int a, int b) {
	return a < b ? a : b;
}
int max(int a, int b) {
	return a > b ? a : b;
}
int main() {
	int t = 1;
	while (~scanf("%d%d", &n, &m) && n && m) {
		for (i = 1; i <= n; i ++)
			for (j = i; j <= n; j ++) {
				if (i == j) map[i][j] = -1;
				else map[i][j] = map[j][i] = -1;
			}
		for (i = 0; i < m; i ++) {
			scanf("%d%d%d", &a, &b, &value);
			map[a][b] = map[b][a] = value;
		}
		for (k = 1; k <= n; k ++)
			for (i = 1; i <= n; i ++)
				for (j = 1; j <= n; j ++) {
					if (min(map[i][k], map[k][j]) != -1)
						map[i][j] = max(map[i][j], min(map[i][k], map[k][j]));
				}
		scanf("%d%d%d", &a, &b, &value);
		printf("Scenario #%d\n", t ++);
		printf("Minimum Number of Trips = %d\n\n", value / (map[a][b] - 1) + (value % map[a][b] ? 1 : 0));
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值