G - The Tourist Guide UVA - 10099

1.题目
G - The Tourist Guide UVA - 10099
Mr. G. works as a tourist guide. His current assignment is to take some tourists from one city to
another. Some two-way roads connect the cities. For each pair of neighboring cities there is a bus
service that runs only between those two cities and uses the road that directly connects them. Each
bus service has a limit on the maximum number of passengers it can carry. Mr. G. has a map showing
the cities and the roads connecting them. He also has the information regarding each bus service. He
understands that it may not always be possible for him to take all the tourists to the destination city
in a single trip. For example, consider the following road map of 7 cities. The edges connecting the
cities represent the roads and the number written on each edge indicates the passenger limit of the bus
service that runs on that road.
Now, if he wants to take 99 tourists from city 1 to city 7, he will require at least 5 trips and the
route he should take is : 1 - 2 - 4 - 7.
But, Mr. G. finds it difficult to find the best route all by himself so that he may be able to take all
the tourists to the destination city in minimum number of trips. So, he seeks your help.
Input
The input will contain one or more test cases. The first line of each test case will contain two integers:
N (N ≤ 100) and R representing respectively the number of cities and the number of road segments.
Then R lines will follow each containing three integers: C1, C2 and P. C1 and C2 are the city numbers
and P (P > 1) is the limit on the maximum number of passengers to be carried by the bus service
between the two cities. City numbers are positive integers ranging from 1 to N. The (R + 1)-th line
will contain three integers: S, D and T representing respectively the starting city, the destination city
and the number of tourists to be guided.
The input will end with two zeroes for N and R.
Output
For each test case in the input first output the scenario number. Then output the minimum number
of trips required for this case on a separate line. Print a blank line after the output of each test case.
Sample Input
7 10
1 2 30
1 3 15
1 4 10
2 4 25
2 5 60
3 4 40
3 6 20
4 7 35
5 7 20
6 7 30
1 7 99
0 0
Sample Output
Scenario #1
Minimum Number of Trips = 5

2.题目大意
导游需要带T个人从S到D,其中先给出各个联通点之间能够带多少个人,然后问至少需要几趟才能从S到D。

3.解题思路
我是用floyd变形,找出从S到D的所有可行道路中,能够能载人最多的一条道路,然后把这条道路中载人最少的弄出来,然后算出一共需要多少趟,其中导游是需要来回走接人的,要把导游算上。

4.floyd变形

  基本的floyd在:https://blog.csdn.net/weixin_45674799/article/details/104410012
 这道题需要改变的就是:
  if (min(graph[i][k], graph[k][j]) > graph[i][j])
                    graph[i][j] = min(graph[i][k], graph[k][j]);
  在这里找到最小的那个载人量。

5.AC代码

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
#define maxn 150
#define maxdis 2500000
int graph[maxn][maxn];
int visit[maxn];
int n;
int a[maxn],b[maxn];
double sum[maxn];

int  flyod(int l, int r)
{
    for(int k = 1; k<=n; k++)//中间点
    {
        for(int i = 1; i<=n; i++) //起点
        {
            for(int j = 1; j<=n; j++)//终点
            {
                if (graph[i][k] == -1 || graph[k][j] == -1)
                    continue;
                if (min(graph[i][k], graph[k][j]) > graph[i][j])
                    graph[i][j] = min(graph[i][k], graph[k][j]);
            }
        }
    }
    return graph[l][r];
}
int main()
{
    int N;
    int casenum = 1;
    while(scanf("%d%d",&n,&N) == 2 && !(!n&&!N))
    {
        memset(graph,-1,sizeof(graph));

        int   cost, a, b;
        for(int i = 1; i<=N; i++)
        {
            cin>>a>>b>>cost;
            graph[a][b] = graph[b][a] = cost;
        }
        int S, D, T;
        cin>>S>>D>>T;
        printf("Scenario #%d\nMinimum Number of Trips = ",casenum++);
        if( S == D)
        {
            printf("0\n");
            continue;
        }
        int ans = flyod(S,D);
        if(T%(ans-1) == 0)
        {
            printf("%d\n",T/(ans-1));
        }
        else
        {
            printf("%d\n",T/(ans-1)+1);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
1. 智慧社区背景与挑战 随着城市化的快速发展,社区面临健康、安全、邻里关系和服务质量等多方面的挑战。华为技术有限公司提出智慧社区解决方案,旨在通过先进的数字化技术应对这些问题,提升城市社区的生活质量。 2. 技术推动智慧社区发展 技术进步,特别是数字化、无线化、移动化和物联化,为城市社区的智慧化提供了可能。这些技术的应用不仅提高了社区的运行效率,也增强了居民的便利性和安全性。 3. 智慧社区的核心价值 智慧社区承载了智慧城市的核心价值,通过全面信息化处理,实现对城市各个方面的数字网络化管理、服务与决策功能,从而提升社会服务效率,整合社会服务资源。 4. 多层次、全方位的智慧社区服务 智慧社区通过构建和谐、温情、平安和健康四大社区模块,满足社区居民的多层次需求。这些服务模块包括社区医疗、安全监控、情感沟通和健康监测等。 5. 智慧社区技术框架 智慧社区技术框架强调统一平台的建设,设立数据中心,构建基础网络,并通过分层建设,实现平台能力及应用的可持续成长和扩展。 6. 感知统一平台与服务方案 感知统一平台是智慧社区的关键组成部分,通过统一的RFID身份识别和信息管理,实现社区服务的智能化和便捷化。同时,提供社区内外监控、紧急救助服务和便民服务等。 7. 健康社区的构建 健康社区模块专注于为居民提供健康管理服务,通过整合医疗资源和居民接入,实现远程医疗、慢性病管理和紧急救助等功能,推动医疗模式从治疗向预防转变。 8. 平安社区的安全保障 平安社区通过闭路电视监控、防盗报警和紧急求助等技术,保障社区居民的人身和财产安全,实现社区环境的实时监控和智能分析。 9. 温情社区的情感沟通 温情社区着重于建立社区居民间的情感联系,通过组织社区活动、一键呼叫服务和互帮互助平台,增强邻里间的交流和互助。 10. 和谐社区的资源整合 和谐社区作为社会资源的整合协调者,通过统一接入和身份识别,实现社区信息和服务的便捷获取,提升居民生活质量,促进社区和谐。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值