UVA 10037 - Bridge(贪心)

Problem D: Bridge

n  people wish to cross a bridge at night. A group of at most two people may cross at any time, and each group must have a flashlight. Only one flashlight is available among the  n  people, so some sort of shuttle arrangement must be arranged in order to return the flashlight so that more people may cross.

Each person has a different crossing speed; the speed of a group is determined by the speed of the slower member. Your job is to determine a strategy that gets all n people across the bridge in the minimum time.

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The first line of input contains n, followed by n lines giving the crossing times for each of the people. There are not more than 1000 people and nobody takes more than 100 seconds to cross the bridge.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

The first line of output must contain the total number of seconds required for all n people to cross the bridge. The following lines give a strategy for achieving this time. Each line contains either one or two integers, indicating which person or people form the next group to cross. (Each person is indicated by the crossing time specified in the input. Although many people may have the same crossing time the ambiguity is of no consequence.) Note that the crossings alternate directions, as it is necessary to return the flashlight so that more may cross. If more than one strategy yields the minimal time, any one will do.

Sample Input

1

4
1
2
5
10

Sample Output

17
1 2
1
5 10
2
1 2

题意:有一座桥,有n个人想过桥,每个人速度为ai,现在过桥可以一个人或两个人过桥,只有一盏灯,要有灯才能过桥,如果两人一起过,速度取决于慢的那个人的速度,问最快时间和过桥方法。

思路:贪心,有n个人,那么每次肯定过2个人,然后一个人送灯回来,这样一共要n + 1躺,仔细分析会发现有两种最优方案:设最快为a1,第二快为a2,最慢为an,第二慢为an-1,情况一:a1,a2,过去,a1回来,an,an-1过去,a2回来。时间a2 + a1 + an + a2情况2:a1,an过去,a1回来,a1,an-1过去,a1,回来。时间an + a1 + an - 1 + a1。只要比较哪种快就用哪种即可

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define max(a,b) (a)>(b)?(a):(b)
#define min(a,b) (a)<(b)?(a):(b)
using namespace std;

const int N = 1005;

int t, n, a[N];

void init() {
	scanf("%d", &n);
	for (int i = 1; i <= n; i++)
		scanf("%d", &a[i]);
}

int cal() {
	int sum = a[2];
	for (int i = n - 2; i >= 2; i -= 2)
		sum += min(a[i + 2] + a[2] * 2 + a[1], a[i + 2] + a[i + 1] + a[1] * 2);
	if (n % 2) sum += a[1] + a[3];
	return sum;
}

void print() {
	for (int i = n - 2; i >= 2; i -= 2) {
		if(a[i + 2] + a[2] * 2 + a[1] < a[i + 2] + a[i + 1] + a[1] * 2) {
			printf("%d %d\n%d\n%d %d\n%d\n", a[1], a[2], a[1], a[i + 1], a[i + 2], a[2]);
		}
		else {
			printf("%d %d\n%d\n%d %d\n%d\n", a[1], a[i + 2], a[1], a[1], a[i + 1], a[1]);
		}
	}
	if (n % 2) {
		printf("%d %d\n%d\n", a[1], a[3], a[1]);
	}
	printf("%d %d\n", a[1], a[2]);
}

void solve() {
	sort(a + 1, a + n + 1);
	if (n == 1)
		printf("%d\n%d\n", a[1], a[1]);
	else if (n == 2)
		printf("%d\n%d %d\n", a[2], a[1], a[2]);
	else {
		printf("%d\n", cal());
		print();
	}
	if (t) printf("\n");
}

int main() {
	scanf("%d", &t);
	while (t--) {
		init();
		solve();
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值