UVA 10120 - Gift?!(搜索+规律)


 Problem D. Gift?! 

The Problem

There is a beautiful river in a small village. N rocks are arranged in a straight line numbered 1 to N from left bank to the right bank, as shown below.

[Left Bank] - [Rock1] - [Rock2] - [Rock3] - [Rock4] ... [Rock n] - [Right Bank]

The distance between two adjacent rocks is exactly 1 meter, while the distance between the left bank and rock 1 and the distance between Rock n and the right bank are also 1 meter.

Frog Frank was about to cross the river, his neighbor Frog Funny came to him and said,

'Hello, Frank. Happy Children's Day! I have a gift for you. See it? A little parcel on Rock 5.'

'Oh, that's great! Thank you! I'll get it.'

'Wait...This present is for smart frogs only. You can't get it by jumping to it directly.'

'Oh? Then what should I do?'

'Jump more times. Your first jump must be from the left bank to Rock 1, then, jump as many times as you like - no matter forward or backward, but your ith jump must cover 2*i-1 meters. What's more, once you return to the left bank or reach the right bank, the game ends, and no more jumps are allowed.'

'Hmmm, not easy... let me have a think!' Answered Frog Frank, 'Should I give it a try?'

The Input

The input will contain no more than 2000 test cases. Each test case contains a single line. It contains two positive integers N (2<=N<=10^6), and M (2<=M<=N), M indicates the number of the rock on which the gift is located. A test case in which N=0, M=0 will terminate the input and should not be regarded as a test case.

The Output

For each test case, output a single line containing 'Let me try!' If it's possible to get to Rock m, otherwise, output a single line containing 'Don't make fun of me!'

Sample Input

9 5
12 2
0 0

Sample Output

Don't make fun of me!
Let me try!

Note

In test case 2, Frank can reach the gift in this way:

Forward(to rock 4), Forward(to rock 9), Backward(to rock 2, got the gift!)

Note that if Frank jumps forward in his last jump, he will land on the right bank(assume that banks are large enough) and thus, lost the game.

题意:n个石头,最终目标是m,每次移动1,3,5,7.步,步数递增,次数不限,只要不跳到石头之外就可以了,求是否能跳到m。

思路:n>=49的话,不管什么位置都可以跳到,<49的时候进行搜索。

代码:

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;

int n, m;
struct State {
	int v, k;
}p;

bool bfs() {
	queue<State>Q;
	p.v = 1; p.k = 3;
	Q.push(p);
	while (!Q.empty()) {
		p = Q.front(); Q.pop();
		if (p.v == m) return true;
		State q = p; q.v += q.k; q.k += 2;
		if (q.v > 0 && q.v <= n)
			Q.push(q);
		q = p; q.v -= q.k; q.k += 2;
		if (q.v > 0 && q.v <= n)
			Q.push(q);
	}
	return false;
}

void solve() {
	if (n <= 49 && !bfs()) printf("Don't make fun of me!\n");
	else printf("Let me try!\n");
}

int main() {
	while (~scanf("%d%d", &n, &m) && n + m) {
		solve();
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值