UVA 1292 - Strategic game(树形dp)

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier (at the node 1).

Input 

The input file contains several data sets in text format. Each data set represents a tree with the following description:
  • the number of nodes
  • the description of each node in the following format:
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 � node_identifiernumber_of_roads
    or
    node_identifier:(0)
The node identifiers are integer numbers between  0  and  n-1 , for  n  nodes ( 0 < n ≤ 1500 ). Every edge appears only once in the input data.

Output 

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers).

Sample Input 

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output 

1
2

题意:在一幅图上,结点放置士兵,使得所有的边能观察到,要求士兵数最少。

思路:明显的树形dp,dp[u][0]表示结点u不选,dp[u][1]表示结点u选,如果不选,那么子结点必须选,如果已选子节点就可选可不选,状态转移方程为

dp[u][0] += dp[v][1]; dp[u][1] += min(dp[v][0], dp[v][1]);

代码:

#include <stdio.h>
#include <string.h>
#include <vector>
#define INF 0x3f3f3f3f
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
using namespace std;
const int N = 1505;
int n, dp[N][2], vis[N];
vector<int> g[N];

void dfs(int u) {
	vis[u] = 1;
	dp[u][0] = 0;
	dp[u][1] = 1;
	for (int i = 0; i < g[u].size(); i++) {
		int v = g[u][i];
		if (vis[v]) continue;
		dfs(v);
		dp[u][0] += dp[v][1];
		dp[u][1] += min(dp[v][0], dp[v][1]);
	}
}
int solve() {
	int ans = 0;
	memset(vis, 0, sizeof(vis));
	for (int i = 0; i < n; i++) {
		if (vis[i]) continue;
		dfs(i);
		ans += min(dp[i][0], dp[i][1]);
	}
	return ans;
}

int main() {
	while (~scanf("%d", &n)) {
		memset(g, 0, sizeof(g));
		int u, num, v;
		for (int i = 0; i < n; i++) {
			scanf("%d%*c%*c%d%*c", &u, &num);
			while (num--) {
				scanf("%d", &v);
				g[u].push_back(v);
				g[v].push_back(u);
			}
		}
		printf("%d\n", solve());
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值