微软2016实习生笔试--第一题Font Size

#1288 : Font Size

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)  

So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.


For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入
2
1 10 4 3
10
2 10 4 3
10 10
样例输出
3
2
代码如下:
#include <iostream>
#include <vector>
#include <cstring>
using namespace std;

int main()
{
	int N;  //保存要处理的任务数
	while(cin >> N)
	{
		int *parNum = new int[N];           // N组任务的段落数
		int *pageNum = new int[N];          // N组任务的页数
		int *width = new int[N];            // N组任务的屏幕宽度
		int *height = new int[N];           // N组任务的屏幕高度
		vector<vector<int> > parWord(N);    // N组任务的每一段落的字数
		for(int i = 0; i < N; i++)
		{
			cin >> parNum[i] >> pageNum[i] >> width[i] >> height[i];
			parWord[i].resize(parNum[i]);
			for(int j = 0; j < parNum[i]; j++)
				cin >> parWord[i][j];
		}

		int *result = new int[N];           // 保存最终结果
		memset(result, 0, N*sizeof(int));
		for(int i = 0; i < N; i++)
		{
			int sumWord = 0;
			for(int j = 0; j < parNum[i]; j++)
				sumWord += parWord[i][j];

			while((width[i]/(result[i]+1)) * (height[i]/(result[i]+1)) * pageNum[i] >= sumWord)  // 如果当前字的大小为result[i]+1,计算这些页数能存的总字数,
				result[i]++;                                                                     // 当总字数刚好小于sumWord时,result[i]存放的为正确结果
		}

		for(int i = 0; i < N; i++)                                                               // 输出最终答案
		{
			cout << result[i] <<endl;
		}
		delete[] parNum;
		delete[] pageNum;
		delete[] width;
		delete[] height;
		delete[] result;
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值