F~Help Johnny(13.7.12)

F. Help Johnny
Description
Poor Johnny is so busy this term. His tutor threw lots of hard problems to him and demanded him to
accomplish those problems in a month. What a wicked tutor! After cursing his tutor thousands of times,
Johnny realized that he must start his work immediately.
The very problem Johnny should solve firstly is about a strange machine called Warmouth. In the Warmouth
there are many pairs of balls. Each pair consists of a red ball and a blue ball and each ball is assigned a value.
We can represent a pair in the form of (R, B) in which R is the value of the red ball and B is of the blue one.
Warmouth has a generator to calculate the match value of two pairs. The match value of (R1, B1) and (R2,
B2) is R1*B2+R2*B1. Initially, Warmouth is empty. Pairs are sent into Warmouth in order. Once a new pair
comes, it will be taken into the generator with all the pairs already in Warmouth.
Johnny’s work is to tell his tutor the sum of all match values given the list of pairs in order. As the best
friend of Johnny, would you like to help him?
Input
The first line of the input is T (no more than 10), which stands for the number of lists Johnny received.
Each list begins with “N“(without quotes). N is the number of pairs of this list and is no more than 100000.
The next line gives N pairs in chronological order. The 2i-th number is the value of the red ball of the i-th
pair and the (2i+1)-th number is the value of the blue ball of the i-th pair. The numbers are positive integers
and smaller than 100000.
Output
Please output the result in a single line for each list.

Sample Input Sample Output

stdin

2
3
1 3 2 2 3 1
2

4 5 6 7

stdout

26

58

通过题目已给公式可以推导出

                        z1=z1-a[j];
			z2=z2-b[j];
			r=r+(z1*b[j]+z2*a[j])
z1和z2分别为a和b的总和,通过这个公式便可较快的算出答案
代码:
#include<iostream>
using namespace std;
int a[100010],b[100010];
int main(){
	int T;
	cin>>T;
	int n;
	while(T--){
		cin>>n;
		long long z1=0,z2=0,r=0;
		for(int i=0;i<n;i++){
			cin>>a[i]>>b[i];
			z1=z1+a[i];
			z2=z2+b[i];
		}
		for(int j=0;j<n-1;j++){
			z1=z1-a[j];
			z2=z2-b[j];
			r=r+(z1*b[j]+z2*a[j]);
		}
		cout<<r<<endl;
	}
return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值