uva 550 Multiplying by Rotation(模拟)

942 篇文章 2 订阅
109 篇文章 2 订阅

  Multiplying by Rotation 

Warning: Not all numbers in this problem are decimal numbers!


Multiplication of natural numbers in general is a cumbersome operation. In some cases however the product can be obtained by moving the last digit to the front.


Example: 179487 * 4 = 717948


Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:


17 * 4 = 71 (base 9)


as (9 * 1 + 7) * 4 = 7 * 9 + 1

Input 

The input for your program is a textfile. Each line consists of three numbers separated by a space: the base of the number system, the least significant digit of the first factor, and the second factor. This second factor is one digit only hence less than the base. The input file ends with the standard end-of-file marker.

Output 

Your program determines for each input line the number of digits of the smallest first factor with the rotamultproperty. The output-file is also a textfile. Each line contains the answer for the corresponding input line.

Sample Input 

10 7 4
9 7 4
17 14 12

Sample Output 

6
2
4
题目大意:给出进制bas,数b, 乘数c。求一个数bas进制的num,num的要求是各位必须为b,把个位数b放到num的首位形成新的一个数sum,然后sum要等于num * c,输出num的位数。

解题思路:题目很有意思,因为num = tem.b;而sum=b.tem;也就是说,(当前位*c + 进位)模去 bas =当前位的前一位。

#include<iostream>
#include<math.h>
using namespace std;

int main(){
	int bas, b, c;
	while (cin >> bas >> b >> c){
		int cnt = 0, p = 0, sum, over = b;
		while (1){
			cnt++;
			sum = b * c + p;
			b = sum % bas;
			p = sum / bas;

			if (over == b && p == 0)
				break;
		}
		cout << cnt << endl;
	}	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值