UVa550 Multiplying by Rotation


 Multiplying by Rotation 

Warning: Not all numbers in this problem are decimal numbers!


Multiplication of natural numbers in general is a cumbersome operation. In somecases however the product can be obtained by moving the last digit to the front.


Example: 179487 * 4 = 717948


Of course this property depends on the numbersystem you use, in the aboveexample we used the decimal representation. In base 9 we have a shorter example:


17 * 4 = 71 (base 9)


as (9 * 1 + 7) * 4 = 7 * 9 + 1

Input 

The input for your program is a textfile. Each line consists of three numbers separated by a space:the base of the number system, the least significant digit of the first factor, and the second factor.This second factor is one digit only hence less than the base. The input file ends with the standardend-of-file marker.

Output 

Your program determines for each input line the number of digits of the smallest first factor withthe rotamultproperty. The output-file is also a textfile. Each line contains the answer for thecorresponding input line.

Sample Input 

10 7 4
9 7 4
17 14 12

Sample Output 

6
2
4



Miguel A. Revilla
1998-03-10

这道题目看起来很复杂,但要理解了就会发现只要套公式循环即可,题目是在n进制下,给予一个乘数因子和一个尾数。要求求出某数能在该进制下通过乘法将该尾数从此数的尾部移动到首部,其他数字不变,通过tmp % system * factor + tmp / system循环,模拟乘法过程求出首部,不断判断首部是否等于尾部,并在每次循环中使某数长度+1,最后输出长度。
#include <iostream>
using namespace std;

int main() {
	int system,last,factor;

	while (cin >> system >> last >> factor) {
		int tmp = factor * last;
		int cnt = 1;
		while (1) {
			if (last == tmp)
				break;
			tmp = tmp % system * factor + tmp / system;
			cnt++;
		}
		cout << cnt << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值