HDU 4927 Series 1

Problem Description
Let A be an integral series {A 1, A 2, . . . , A n}.

The zero-order series of A is A itself.

The first-order series of A is {B 1, B 2, . . . , B n-1},where B i = A i+1 - A i.

The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1).

Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
 

Input
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10).

For each test case:
The first line contains a single integer n(1<=n<=3000), which denotes the length of series A.
The second line consists of n integers, describing A 1, A 2, . . . , A n. (0<=A i<=10 5)
 

Output
For each test case, output the required integer in a line.
 

Sample Input
  
  
2 3 1 2 3 4 1 5 7 2
 

Sample Output
  
  
0 -5

题意:求最后合并的数是多少

思路:JAVA高精度,推出来后发现是系数是杨辉三角,处理出系数后计算结果

import java.math.BigInteger;
import java.util.*;
import java.io.*;

/**
 * Created by acer on 14-8-7.
 */
public class Main {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int t, n;
        t = cin.nextInt();
        while (t != 0) {
            t--;
            n = cin.nextInt();
            BigInteger arr[] = new BigInteger[n];
            for (int i = 0; i < n; i++) {
                arr[i] = cin.nextBigInteger();
            }
            if (n == 1) {
                System.out.println(arr[0]);
                continue;
            }
            BigInteger ans = new BigInteger("0");
            BigInteger C[] = new BigInteger[n + 2];
            BigInteger t1 = new BigInteger("0");
            BigInteger t2 = new BigInteger("0");
            C[0] = BigInteger.valueOf(1);
            for (int i = 1; i < n; i++) {
                t1 = BigInteger.valueOf(n-i);
                t2 = BigInteger.valueOf(i);
                C[i] = C[i-1].multiply(t1).divide(t2);
            }

            int flag = 1;
            for (int i = n - 1; i >= 0; i--) {
                if (flag == -1)
                    ans = ans.subtract(arr[i].multiply(C[i]));
                else ans = ans.add(arr[i].multiply(C[i]));
                flag *= -1;
            }
            System.out.println(ans);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值