HDU - 4944 FSF’s game

Problem Description
FSF has programmed a game.
In this game, players need to divide a rectangle into several same squares.
The length and width of rectangles are integer, and of course the side length of squares are integer.

After division, players can get some coins.
If players successfully divide a AxB rectangle(length: A, width: B) into KxK squares(side length: K), they can get A*B/ gcd(A/K,B/K) gold coins.
In a level, you can’t get coins twice with same method.
(For example, You can get 6 coins from 2x2(A=2,B=2) rectangle. When K=1, A*B/gcd(A/K,B/K)=2; When K=2, A*B/gcd(A/K,B/K)=4; 2+4=6; )

There are N*(N+1)/2 levels in this game, and every level is an unique rectangle. (1x1 , 2x1, 2x2, 3x1, ..., Nx(N-1), NxN)

FSF has played this game for a long time, and he finally gets all the coins in the game.
Unfortunately ,he uses an UNSIGNED 32-BIT INTEGER variable to count the number of coins.
This variable may overflow.
We want to know what the variable will be.
(In other words, the number of coins mod 2^32)
 

Input
There are multiply test cases.

The first line contains an integer T(T<=500000), the number of test cases

Each of the next T lines contain an integer N(N<=500000).
 

Output
Output a single line for each test case.

For each test case, you should output "Case #C: ". first, where C indicates the case number and counts from 1.

Then output the answer, the value of that UNSIGNED 32-BIT INTEGER variable.
 

Sample Input
  
  
3 1 3 100
 

Sample Output
 
 
Case #1: 1 Case #2: 30 Case #3: 15662489
Hint
In the second test case, there are six levels(1x1,1x2,1x3,2x2,2x3,3x3) Here is the details for this game: 1x1: 1(K=1); 1x2: 2(K=1); 1x3: 3(K=1); 2x2: 2(K=1), 4(K=2); 2x3: 6(K=1); 3x3: 3(K=1), 9(K=3); 1+2+3+2+4+6+3+9=30


题意:给你个n,让你求在n的范围内,能否将一个矩形分成若干个相同大小为k的正方形,对应有val值,让你统计在n内的所有可能的分数总值

思路:首先我们来试着求解i=1nnigcd(nk,ik),那么我们可以确定的是如果可以把nm的矩形分成大小为k的正方形的话,那么k一定是gcd(n, i)的因子,那么对于一项来说因为公式可以变形
nikgcd(n,i) -> n(ic1+ic2+...) {k枚举所有的可能},那么cj是n的因子,那么icj就是因子对应的系数,我们再从所有的i来讲,对于因子我们可以计算出所有可能的数,比如因子cj,我们可以得到cj, 2cj, 3cj, 4cj....n,那么对应的系数就是我们需要的icj,累加起来计算是:
num[cj]=(1+2+...+ncj)=(1+ncj)(ncj)2

val[n]=i=1nnum[i]

ans[n]=ans[n1]+val[n]


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll __int64
using namespace std;
const int maxn = 500005;
const ll mod = 1ll<<32;

ll num[maxn], dp[maxn];

void cal() {
	for (ll i = 1; i < maxn; i++) 
		for (ll j = i; j < maxn; j += i)
			num[j] += (j/i+1) * (j/i) / 2;
}

void init() {
	memset(num, 0, sizeof(num));
	cal();
	dp[1] = 1;
	for (ll i = 2; i < maxn; i++) {
		dp[i] = dp[i-1] + num[i]*i;
		dp[i] = dp[i] % mod;
	}
}

int main() {
	init();
	int t, n, cas = 1;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		printf("Case #%d: %I64d\n", cas++, dp[n]);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值