HDU - 5033 Building

Problem Description
Once upon a time Matt went to a small town. The town was so small and narrow that he can regard the town as a pivot. There were some skyscrapers in the town, each located at position x i with its height h i. All skyscrapers located in different place. The skyscrapers had no width, to make it simple. As the skyscrapers were so high, Matt could hardly see the sky.Given the position Matt was at, he wanted to know how large the angle range was where he could see the sky. Assume that Matt's height is 0. It's guaranteed that for each query, there is at least one building on both Matt's left and right, and no building locate at his position.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

Each test case begins with a number N(1<=N<=10^5), the number of buildings.

In the following N lines, each line contains two numbers, x i(1<=x i<=10^7) and h i(1<=h i<=10^7).

After that, there's a number Q(1<=Q<=10^5) for the number of queries.

In the following Q lines, each line contains one number q i, which is the position Matt was at.
 

Output
For each test case, first output one line "Case #x:", where x is the case number (starting from 1).

Then for each query, you should output the angle range Matt could see the sky in degrees. The relative error of the answer should be no more than 10^(-4).
 

Sample Input
  
  
3 3 1 2 2 1 5 1 1 4 3 1 3 2 2 5 1 1 4 3 1 4 2 3 5 1 1 4
 

Sample Output
  
  
Case #1: 101.3099324740 Case #2: 90.0000000000 Case #3: 78.6900675260 题意:给你n栋楼,每栋楼有高度和坐标,现在询问你人站在某个位置,能看到的天空的角度 思路:将询问的人和楼组合在一起,排序后,维护一个凸的高度下降的单调栈(可以动手画一下),然后每次查询到人的位置的时候,维护单调栈,使得图形是凸的,那么栈首和这个人就能构成答案了,还有是楼的时候也要维护这个栈,那么前后各遍历一次,就能通过正切值求解了
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
typedef __int64 ll;
using namespace std;

const double PI = acos(-1.0);
const int maxn = 100005;

struct Node {
	int x, h;
	bool operator <(const Node &a)const {
		return x < a.x;
	}
} node[maxn<<2], stk[maxn<<2];
double ans[maxn];
int n, q;

int check(Node &a, Node &b, Node c) {
	if (c.h <= 0)
		c.h = 0;
	return (ll)(a.h - c.h) * (c.x - b.x) >= (ll)(b.h - c.h) * (c.x - a.x);
}

double getAngle(Node a, Node b) {
	return atan((double)(b.x-a.x)/(double)(a.h));
}

void cal() {
	int head = 0;
	for (int i = 0; i < n+q; i++) {
		if (node[i].h <= 0) {
			while (head >= 2 && check(stk[head-2], stk[head-1], node[i]))
				head--;
			ans[-node[i].h] += getAngle(stk[head-1], node[i]);
		}
		else {
			while (head && stk[head-1].h <= node[i].h)
				head--;
			while (head >= 2 && check(stk[head-2], stk[head-1], node[i]))
				head--;
			stk[head++] = node[i];
		}
	}
}

int main() {
	int t, cas = 1;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d%d", &node[i].x, &node[i].h);
		scanf("%d", &q);
		for (int i = 0; i < q; i++) {
			scanf("%d", &node[i+n].x);
			node[i+n].h = -i;
		}

		memset(ans, 0, sizeof(ans));
		sort(node, node+n+q);

		cal();

		reverse(node, node+n+q);
		for (int i = 0; i < n+q; i++)
			node[i].x = 10000000 - node[i].x;

		cal();

		printf("Case #%d:\n", cas++);
		for (int i = 0; i < q; i++)
			printf("%.10lf\n", ans[i] * 180.0 / PI);
	}
	return 0;
}



  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值