HDU 1892 See you~【树状数组】

See you~

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2658 Accepted Submission(s): 841


Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.
There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries.
For each "S" query, just print out the total number of books in that area.

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4

Author
Sempr|CrazyBird|hust07p43

Source

Recommend
lcy
二维树状数组。
代码
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string.h>
using namespace std;
int aa[1005][1005]={0},bb[1005][1005];
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x,int y)
{
    int ans=0;
    int i,j;
    for(i=x;i>0;i-=lowbit(i))
    for(j=y;j>0;j-=lowbit(j))
    {
        ans+=aa[i][j];
    }
    return ans;
}
int updata(int x,int y,int a)
{
    int i,j;
    for(i=x;i<=1001;i+=lowbit(i))
    for(j=y;j<=1001;j+=lowbit(j))
    aa[i][j]+=a;
}
int main()
{
    int total,tt,i,j,sss,cc=0,maxx,maxy,minx,miny;
    int x1,y1,x2,y2,add;
    char ss;
    scanf("%d",&total);
    for(int ii=1;ii<=total;ii++)
    {

        for(i=1;i<=1001;i++)
        for(j=1;j<=1001;j++)
        {
            aa[i][j]=lowbit(i)*lowbit(j);//updata(i,j,1);
            bb[i][j]=1;
        }
        scanf("%d",&tt);

        printf("Case %d:\n",ii);
        while(tt--)
        {
            getchar();
            scanf("%c",&ss);
            if(ss=='S')
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                x1++;y1++;x2++;y2++;//数据范围从0到1000
                maxx=x1>x2?x1:x2;
                minx=x1>x2?x2:x1;
                maxy=y1>y2?y1:y2;
                miny=y1>y2?y2:y1;
                cc+=sum(maxx,maxy);
                cc+=sum(minx-1,miny-1);
                cc-=sum(minx-1,maxy);
                cc-=sum(maxx,miny-1);
                printf("%d\n",cc);
                cc=0;
            }
            else if(ss=='A')
            {
                scanf("%d%d%d",&x1,&y1,&add);
                x1++;y1++;
                updata(x1,y1,add);
                bb[x1][y1]+=add;
            }
            else if(ss=='D')
            {
                scanf("%d%d%d",&x1,&y1,&add);
                x1++;y1++;
                if(bb[x1][y1]>add)
                {
                    add*=(-1);
                    updata(x1,y1,add);
                    bb[x1][y1]+=add;
                }
                else
                {
                    updata(x1,y1,(-1)*bb[x1][y1]);
                    bb[x1][y1]=0;
                }
            }
            else if(ss=='M')
            {
                scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&add);
                x1++;y1++;x2++;y2++;
                if(bb[x1][y1]>add)
                {
                    updata(x1,y1,(-1)*add);
                    bb[x1][y1]-=add;
                    updata(x2,y2,add);
                    bb[x2][y2]+=add;
                }
                else
                {
                    updata(x1,y1,(-1)*bb[x1][y1]);
                    updata(x2,y2,bb[x1][y1]);
                    bb[x2][y2]+=bb[x1][y1];
                    bb[x1][y1]=0;
                }

            }
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值