HDU - 1892 - See you~ (树状数组)

See you~

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 5687    Accepted Submission(s): 1805


Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. 
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. 
There are 4 kind of queries, sum, add, delete and move. 
For example: 
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. 
A x1 y1 n1 means I put n1 books on the position (x1,y1) 
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. 
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. 
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 
 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. 
For each "S" query, just print out the total number of books in that area. 
 

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4
 

Author
Sempr|CrazyBird|hust07p43
 

Source
 

题意:有一个房间,可以分割为1000*1000的网格,然后每个格子里刚开始有1本书,有以下四种操作:
1、S,查找以(x1,y1)-(x2,y2)为对角线的矩形内有多少本书,并输出
2、A,在(x1,y1)位置加放n1本书
3、D,从(x1,y1)位置拿走n1本书(若该位置的书少于n1本则全拿走)
4、M,从(x1,y1)位置拿走n1本书(若该位置的书少于n1本则全拿走)到(x2,y2)位置

思路:
就是求以(1,1)-(x,y)为对角线的矩形内含有的书本数,∑[(i,1)-(i,y)] (1 ≤ i ≤ y)  第i行从(i,1)至(i,y)的区间求和,再对所有的求出的和进行求和,就是进行两次区间求和,然后加加减减,得到以(x1,y1)-(x2,y2)为对角线的矩形内有多少本书。
在(x,y)点改变书本数量会影响从该点开始的右上方所有点的区间和。
具体实现不知道要怎么讲。。还是看代码吧

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
#define ll long long
const ll maxn = 1000+10;
int T,Q,x1,x2,y1,y2,n1,a[maxn][maxn],cas = 0,b[maxn][maxn];
char s[5];
int lowbit(int x) {return x&-x;}
void add_and_del(int x,int y,int vay)
{
    for(;y<maxn;y+=lowbit(y))
        for(int xx=x;xx<maxn;xx+=lowbit(xx))
            b[xx][y] += vay;
//    for(int xx=x;xx<maxn;xx+=lowbit(xx))
//        b[xx][y] += vay;                  只有一个方向的树状数组
}
ll sum(int x,int y)
{
    ll ans = 0;
//    for(;x>0;x--)
//      for(int yy=y;yy>0;yy-=lowbit(yy))
//          ans += b[x][yy];                //一个用树状数组求区间和,另一个就是直接求和,较慢
    for(;x>0;x-=lowbit(x))
        for(int yy=y;yy>0;yy-=lowbit(yy))
            ans += b[x][yy];
    return ans;
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        printf("Case %d:\n",++cas);
        memset(b,0,sizeof b);
        scanf("%d",&Q);
        for(int i=1;i<maxn;i++)
        {
            for(int j=1;j<maxn;j++)
            {
                a[i][j] = 1;
                add_and_del(i, j, 1);
            }
        }
        while(Q--)
        {
            scanf("%s",s);
            if(s[0]=='S')//searcx
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                if(y1>y2) swap(y1,y2);
                if(x1>x2) swap(x1,x2);
                //(x1,y1)为矩形左下角,(x2,y2)为矩形右上角
                x1++,y1++,x2++,y2++;
                ll A = sum(x2,y2), B = sum(x1-1,y1-1), C = sum(x1-1,y2), D = sum(x2,y1-1);
                printf("%lld\n",A + B - C - D);
            }
            else if(s[0]=='A')//add
            {
                scanf("%d%d%d",&x1,&y1,&n1);
                x1++,y1++;
                a[x1][y1]+=n1;
                add_and_del(x1, y1, n1);
            }
            else if(s[0]=='D')//deyete
            {
                scanf("%d%d%d",&x1,&y1,&n1);
                x1++,y1++;
                n1 = min(a[x1][y1],n1);
                a[x1][y1]-=n1;
                add_and_del(x1, y1, -n1);
            }
            else//'M' move
            {
                scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&n1);
                x1++,y1++,x2++,y2++;
                n1 = min(a[x1][y1],n1);
                a[x1][y1]-=n1,a[x2][y2]+=n1;
                add_and_del(x1, y1, -n1);//(x1,y1) 移走n1个
                add_and_del(x2, y2, n1);//(x2,y2) 放入n1个
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值