统计字符串中字符的种类

Description

编写一函数,由实参传来一个字符串,统计此字符串中字母、数字、空格和其它字符的个数,在主函数中输入字符串以及输出上述结果。 只要结果,别输出什么提示信息。

Input

一行字符串

Output

统计数据,4个数字,空格分开。

Sample Input

!@#$%^QWERT    1234567

Sample Output

5 7 4 6


#include<cstdio>
#include<cstdlib>
#include<cstring>

char str[100];
int* _stat(int _count[4],char* str)
{
    int len = strlen(str);
    for(int i = 0 ; i < len ; i++)
    {
        if((str[i] >= 'A' && str[i] <= 'Z') || (str[i] >= 'a' && str[i] <= 'z'))
            _count[0]++;
        else if(str[i] >= '0' && str[i] <= '9')
            _count[1]++;
        else if(str[i] == ' ')
            _count[2]++;
        else
            _count[3]++;
    }
    return _count;
}

int main()
{

    while(gets(str) != NULL)
    {
        int *res = new int[4];
        memset(res , 0 , 4*sizeof(int));
        res = _stat(res , str);
        for(int i = 0 ; i < 3 ; i++)
            printf("%d " , res[i]);
        printf("%d" , res[3]);
        delete[] res;
    }


    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值