POJ 1129 Channel Allocation

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10768 Accepted: 5521

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source

 
题意:
给出一中继器及其相邻中继器,要求相邻两中继器播放的频道不同,求至少需播放多少频道
 
代码:
#include<cstdio>
#include<cstring>
#include<string>
#define N 27

typedef struct NODE
{
	int next[N];   //存放一个结点的相邻结点 例:point[i].next[j]存放第i个结点的第j个相邻结点
	int num;       //存放一个结点的相邻结点个数
}node;

int color[N];      //color[i]存放第i个结点当前的播放频道
bool visited[N];   //visited[i]标记第i种频道有没有被播放

int main()
{
	int i,j,k,n;

	while(scanf("%d",&n)!=EOF && n)
	{
		getchar();         //换行符
		node point[N];
		for(i=1;i<=n;i++)
		{
			getchar();     //结点
			getchar();     //冒号
			char ch;

			point[i].num=0;
			
			while((ch=getchar())!='\n')
			{
				k=ch%('A'-1);   //将字母转换成数字 A->1,C->3
				point[i].next[++point[i].num]=k;
			}
		}

		memset(color,0,sizeof(color));
		color[1]=1;
		int max_color=1;

		for(i=1;i<=n;i++)
		{
			memset(visited,false,sizeof(visited));
			color[i]=n+1;          //初始播放最大的频道
			for(j=1;j<=point[i].num;j++)
			{
				k=point[i].next[j];
				if(color[k]) visited[color[k]]=true;   //若一个结点的相邻结点已播放该频道,标记
			}
			for(j=1;j<=n;j++)
			{
				if(!visited[j] && color[i]>j)
				{
					color[i]=j;
					break;
				}
			}

			if(max_color<color[i]) max_color=color[i];
		}

		if(max_color==1) printf("%d channel needed.\n",max_color);
		else printf("%d channels needed.\n",max_color);
	}
	return 0;
}

思路:

一个有N个节点的无向图,要求对每个节点进行染色,使得相邻两个节点颜色都不同,问最少需要多少种颜色?

题目就变成了一个经典的图的染色问题。

 

据说可以用“四色定理”做,那个等我搞懂了再说吧。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值