poj 1129 Channel Allocation

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14394 Accepted: 7332

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source

提示

题意:

无线电台的覆盖范围很大,因为我们通过中继器进行扩大,但是要注意的是,中继器的信号干扰是很强的,同一频道用相邻中继器会使它们之间的信号互相干扰,从而收听质量大大下降,所以同一频道的电台尽量使用不相邻的中继器。

我们有每个中继器相邻情况的列表,最少能有几个频道用中继器扩大不会有干扰。

思路:

把这个问题转化到在无向图中,相连的两个点不能有相同的颜色,用最少的颜色涂满全部点。这样就比较好思考了,这题数据比较水,放心去做吧。

示例程序

Source Code

Problem: 1129		Code Length: 1265B
Memory: 392K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int map[26][26],v[26],min,bug;
int judge(int pos,int chan,int n)				//相邻部分是否有重复的
{
    int i;
    for(i=0;n>i;i++)
    {
        if(map[pos][i]==1&&chan==v[i])
        {
            return 0;
        }
    }
    return 1;
}
void dfs(int pos,int k,int n)
{
    int i;
    if(bug==1)
    {
        return;
    }
    if(pos==n)
    {
        bug=1;
        return;
    }
    for(i=0;k>i;i++)
    {
        if(judge(pos,i,n)==1)
        {
            v[pos]=i;
            dfs(pos+1,k,n);
            v[pos]=-1;						//回溯
        }
    }
    if(bug==0)							//有干扰就增加一个频道
    {
        min++;
        dfs(pos,k+1,n);
    }
}
int main()
{
    int n,i,i1,num;
    char ch[28];
    scanf("%d",&n);
    while(n!=0)
    {
        bug=0;
        memset(map,0,sizeof(map));
        memset(v,-1,sizeof(v));
        for(i=0;n>i;i++)
        {
            scanf("%s",ch);
            for(i1=2;ch[i1]!='\0';i1++)
            {
                map[ch[0]-'A'][ch[i1]-'A']=1;
                map[ch[i1]-'A'][ch[0]-'A']=1;
            }
        }
        min=1;						//最少为1
        dfs(0,1,n);
        if(min==1)
        {
            printf("1 channel needed.\n");
        }
        else
        {
            printf("%d channels needed.\n",min);
        }
        scanf("%d",&n);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值