POJ 2159 Ancient Cipher

Ancient Cipher
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25115 Accepted: 8305

Description

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT".
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO".
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP".
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input

Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet.
The lengths of both lines of the input are equal and do not exceed 100.

Output

Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.

Sample Input

JWPUDJSTVP
VICTORIOUS

Sample Output

YES

Source

 
题意:
判断加密文和原文是否对应
 
代码:
#include<iostream>
#include<string>
#include<algorithm>
#include<cstring>
using namespace std;

int main()
{
	string origin;
	string change;
	int ori[27];
	int cha[27];

	while(cin>>change!=NULL)
	{
		memset(ori,0,sizeof(ori));
		memset(cha,0,sizeof(cha));

		for(int i=0;i<change.size();i++)
			cha[change[i]-'A']++;
		sort(cha,cha+26);

		cin>>origin;
		for(int i=0;i<origin.size();i++)
			ori[origin[i]-'A']++;
		sort(ori,ori+26);

		for(int i=0;i<26;i++)
			if(cha[i]!=ori[i])
			{
				cout<<"NO"<<endl;
				return 0;
			}
		cout<<"YES"<<endl;
	}
	return 0;
}

思路:
这道题放在了水题的分类中,但貌似没有想象中的水。。
题中的加密方法用了凯撒加密,而凯撒加密中字母移动的位数是不确定的,而题中字母乱序时的顺序也是不确定的
所以解题方法并不是将原文通过一步步加密处理后与加密文比较这么简单
凯撒加密的特点是,相同字母通过加密后所得字母的个数(或称频率)与原字母是相同的
也就是说,不管怎样加密,统计字母频数后排序,相同位上的数应该是相等的
这就是这道题的正确解法
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值