POJ2159Ancient Cipher

Ancient Roman empire had a strong government system with various departments, including a secretservice department. Important documents were sent between provinces and the capital in encryptedform to prevent eavesdropping. The most popular ciphers in those times were so called substitutioncipher and permutation cipher.

Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for allletters must be different. For some letters substitute letter may coincide with the original letter. Forexample, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in thealphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.Permutation cipher applies some permutation to the letters of the message. For example, applyingthe permutation ⟨2, 1, 5, 4, 3, 7, 6, 10, 9, 8⟩ to the message “VICTORIOUS” one gets the message“IVOTCIRSUO”.

It was quickly noticed that being applied separately, both substitution cipher and permutationcipher were rather weak. But when being combined, they were strong enough for those times. Thus,the most important messages were first encrypted using substitution cipher, and then the result wasencrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination ofthe ciphers described above one gets the message “JWPUDJSTVP”.

Archeologists have recently found the message engraved on a stone plate. At the first glance itseemed completely meaningless, so it was suggested that the message was encrypted with some substitutionand permutation ciphers. They have conjectured the possible text of the original message thatwas encrypted, and now they want to check their conjecture. They need a computer program to do it,so you have to write one.Input

Input file contains several test cases. Each of them consists of two lines. The first line contains themessage engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, sothe encrypted message contains only capital letters of the English alphabet. The second line containsthe original message that is conjectured to be encrypted in the message on the first line. It also containsonly capital letters of the English alphabet.

The lengths of both lines of the input file are equal and do not exceed 100.

Output

For each test case, print one output line. Output ‘YES’ if the message on the first line of the input filecould be the result of encrypting the message on the second line, or ‘NO’ in the other case.

Sample Input

JWPUDJSTVP

VICTORIOUS

MAMA

ROME

HAHA

HEHE

AAA

AAA

NEERCISTHEBEST

SECRETMESSAGE

SSample Output

YES

NO

YES

YES

NO

啊啊啊啊啊啊啊!!!!

都怪我英语不好,被它让进去坑了,还以为是水题,把所有的大写字母往前移一个,好长时间后才明白,比如‘A’可以对应‘A’~‘Z’   26个字母,只要下面的字母出现的频率跟上面‘A’出现的频率一样,然后再看后面的

#include<stdio.h>
#include<string.h>
void sort(int [],int);
int f(char [],char []);
int main()
{
	char s[101],s1[101];
	static int b[30],b1[30];
	int i,flag;
	while(scanf("%s%s",s,s1)!=EOF)
	{
		
		memset(b,0,sizeof(b));//初始化 
		memset(b1,0,sizeof(b1));
		flag=1;
		for(i=0;s[i]!='\0';i++)
		{
			b[s[i]-'A']++;
			b1[s1[i]-'A']++;
		}
		sort(b,26);
		sort(b1,26);
		for(i=0;i<26;i++)
			if(b[i]!=b1[i])
			{
				flag=0;
				break;
			}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");	
	}
	return 0;
}
void sort(int b[],int n)
{
	int i,j,t;
	for(i=1;i<n;i++)
		for(j=0;j<n-i;j++)
			if(b[j]<b[j+1])
			{
				t=b[j];b[j]=b[j+1];b[j+1]=t;
			}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kunsir_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值