【POJ】1002 487-3279

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3


字符映射么?

不太清楚。反正身为TLE狂魔的我看到这种略水的题目都是直接暴力。

输入一串字符然后独个检查字符串中的每个字符,'0'-'9'直接直接存,'A'-'Z'之间字符转换再存,'-'直接略过。

在做这题的时候我又干了打自己脸的事,map[]数组我存成了int类型,调试的时候【全是乱码】。我自己继续打脸去,“啪啪啪——”。

需要注意的是,sort函数不能直接排序二维字符数组,但可以把二维字符数组转换成用结构体储存,再加上一个bool cmp函数,就可以直接排序了。

cmp函数+sort排序:

struct Array
{
    char c[233];
}test[233];
bool cmp(Array a1,Array a2)
{
  return strcmp(a1.c,a2.c)<0;
}
sort(test,test+n,cmp);


揍系芥末流弊!


怒贴代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>

using namespace std;

char map[26]={'2','2','2','3','3','3','4','4','4','5','5','5','6','6','6','7','7','7','7','8','8','8','9','9','9','9'};

struct Phone
{
    char s[11];
};
Phone p[100010];

bool cmp(Phone p1,Phone p2)
{
  return strcmp(p1.s,p2.s)<0;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int cas;
        for(cas=0;cas<n;cas++)
        {
            int k=0;
            char num[100];
            scanf("%s",num);
            for(int i=0;num[i]!='\0';i++)
            {
                if(k==3)
                {
                    p[cas].s[k]='-';
                    k++;
                }
                if(num[i]>='0'&&num[i]<='9')
                    p[cas].s[k]=num[i];
                else if(num[i]>='A'&&num[i]<='Z')
                    p[cas].s[k]=map[num[i]-'A'];
                else if(num[i]=='-')
                    continue;
                k++;
            }
        }
        sort(p,p+n,cmp);
        int flag=1;
        int count=1;
        for(cas=1;cas<n;cas++)
        {
            //printf("%s\n",p[cas].s);
            if(strcmp(p[cas].s,p[cas-1].s)==0)
            {
                flag=0;
                count++;
            }
            else
            {
                if(count>1)
                    printf("%s %d\n",p[cas-1].s,count);
                count=1;
            }
        }
        if(count>1)
            printf("%s %d\n",p[cas-1].s,count);
        if(flag)
            printf("No duplicates.\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值