PAT_1020: Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
备注:具体方法参见文章 http://www.cnblogs.com/fzhe/archive/2013/01/07/2849040.html
#include<iostream>
#include<queue>
using namespace std;

typedef struct node
{
	int id;
	struct node* left;
	struct node* right;
}NODE;


NODE* ConstructTree(int* post_order, int* in_order, int n_nodes)
{
	if(n_nodes==0)
		return NULL;
	NODE* root = new NODE;
	root->id = post_order[n_nodes-1];

	int rootIndex;
	for(rootIndex=0;rootIndex<n_nodes;rootIndex++)
	{
		if(in_order[rootIndex] == root->id)
			break;
	}
	root->left = ConstructTree(post_order,in_order,rootIndex);
	root->right = ConstructTree(post_order+rootIndex,in_order+rootIndex+1,n_nodes-rootIndex-1);

	return root;
}

void LevelOrder(NODE* node)
{
	queue<NODE*> q;

	q.push(node);
	while(!q.empty())
	{
		NODE* n = q.front();
		q.pop();		
		if(n->left)
			q.push(n->left);
		if(n->right)
			q.push(n->right);
		if(!q.empty())
			cout<<n->id<<" ";
		else
			cout<<n->id;
	}
}

int main()
{
	int n_nodes;
	cin>>n_nodes;

	int* post_order = new int[n_nodes];
	int* in_order = new int[n_nodes];

	for(int i=0;i<n_nodes;i++)
		cin>>post_order[i];

	for(int i=0;i<n_nodes;i++)
		cin>>in_order[i];

	NODE* root = ConstructTree(post_order,in_order,n_nodes);
	LevelOrder(root);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值