Meeting point-1

B - Meeting point-1
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

It has been ten years since TJU-ACM established. And in this year all the retired TJU-ACMers want to get together to celebrate the tenth anniversary. Because the retired TJU-ACMers may live in different places around the world, it may be hard to find out where to celebrate this meeting in order to minimize the sum travel time of all the retired TJU-ACMers. 
There is an infinite integer grid at which N retired TJU-ACMers have their houses on. They decide to unite at a common meeting place, which is someone's house. From any given cell, only 4 adjacent cells are reachable in 1 unit of time.
Eg: (x,y) can be reached from (x-1,y), (x+1,y), (x, y-1), (x, y+1).
Finding a common meeting place which minimizes the sum of the travel time of all the retired TJU-ACMers.
 

Input

The first line is an integer T represents there are T test cases. (0<T <=10)
For each test case, the first line is an integer n represents there are n retired TJU-ACMers. (0<n<=100000), the following n lines each contains two integers x, y coordinate of the i-th TJU-ACMer. (-10^9 <= x,y <= 10^9)
 

Output

For each test case, output the minimal sum of travel times.
 

Sample Input

     
     
4 6 -4 -1 -1 -2 2 -4 0 2 0 3 5 -2 6 0 0 2 0 -5 -2 2 -2 -1 2 4 0 5 -5 1 -1 3 3 1 3 -1 1 -1 10 -1 -1 -3 2 -4 4 5 2 5 -4 3 -1 4 3 -1 -2 3 4 -2 2
 

Sample Output

     
     
26 20 20 56

Hint

In the first case, the meeting point is (-1,-2); the second is (0,0), the third is (3,1) and the last is (-2,2)
 


很久没写题解了,昨天做了一次小练习,感觉颓废了呀。“2012 Multi-University Training Contest 2”其中B题昨天始终没有搞定,就差一点点呀。

B题的思路被我的一个学弟一下想出来了,开始对此算法报有怀疑的态度,最后自己想了几种方法没能实现。还是采取学弟的方法。最后总结发现我们错在__int64上面。

题意:

就是给你n个点,要找出一个点求出其他点到这点的哈夫曼距离最短,求出最短距离。

具体代码:


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <iostream>
#include<algorithm>
#define M 100005
using namespace std;
#define LL __int64
struct point {
    LL x;
    LL y;
    int id;
} p[M];

bool cmpx(point e1,point e2) {
    return e1.x < e2.x;
}
bool cmpy(point e1,point e2) {
    return e1.y < e2.y;
}
LL temp[M],sumx[M],sumy[M];
int main() {
    int cse;
    cin>>cse;
    while(cse--) {
        int n;
        scanf("%d",&n);
        for(int i=1; i<=n; i++) {
            scanf("%I64d%I64d",&p[i].x,&p[i].y);
            p[i].id = i;
        }


        memset(sumx,0,sizeof(sumx));
        memset(sumy,0,sizeof(sumy));

        sort(p+1, p+n+1, cmpx);

        temp[0] = 0;
        for(int i=1; i<=n; i++)
            temp[i] = temp[i-1] + p[i].x;
        for(int i=1; i<=n; i++)
            sumx[ p[i].id ] = temp[n]  - 2*temp[i-1] + (2*i-n-2)*p[i].x;

        sort(p+1, p+n+1, cmpy);

        temp[0] = 0;
        for(int i=1; i<=n; i++)
            temp[i] = temp[i-1] + p[i].y;
        for(int i=1; i<=n; i++)
            sumy[ p[i].id ] = temp[n] -  2*temp[i-1] + (2*i-n-2)*p[i].y;


        LL ans = sumx[1] + sumy[1];
        for(int i=2; i<=n; i++) {
            if(ans > sumx[i]+sumy[i])
                ans = (sumx[i]+sumy[i]);

        }

        printf("%I64d\n",ans);

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值