HDU 4311 ——Meeting point-1(暴力)

题目:

A - Meeting point-1
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

It has been ten years since TJU-ACM established. And in this year all the retired TJU-ACMers want to get together to celebrate the tenth anniversary. Because the retired TJU-ACMers may live in different places around the world, it may be hard to find out where to celebrate this meeting in order to minimize the sum travel time of all the retired TJU-ACMers. 
There is an infinite integer grid at which N retired TJU-ACMers have their houses on. They decide to unite at a common meeting place, which is someone's house. From any given cell, only 4 adjacent cells are reachable in 1 unit of time. 
Eg: (x,y) can be reached from (x-1,y), (x+1,y), (x, y-1), (x, y+1). 
Finding a common meeting place which minimizes the sum of the travel time of all the retired TJU-ACMers. 
 

Input

The first line is an integer T represents there are T test cases. (0<T <=10) 
For each test case, the first line is an integer n represents there are n retired TJU-ACMers. (0<n<=100000), the following n lines each contains two integers x, y coordinate of the i-th TJU-ACMer. (-10^9 <= x,y <= 10^9) 
 

Output

For each test case, output the minimal sum of travel times.
 

Sample Input

     
     
4 6 -4 -1 -1 -2 2 -4 0 2 0 3 5 -2 6 0 0 2 0 -5 -2 2 -2 -1 2 4 0 5 -5 1 -1 3 3 1 3 -1 1 -1 10 -1 -1 -3 2 -4 4 5 2 5 -4 3 -1 4 3 -1 -2 3 4 -2 2
 

Sample Output

     
     
26 20 20 56

Hint

 In the first case, the meeting point is (-1,-2); the second is (0,0), the third is (3,1) and the last is (-2,2) 
         


题意:有很多人在不同的地方,选择其中一个人的屋子,使得其他人到这个地方去的距离最短,这里的距离是指x轴和y轴方向加起来。而不是欧几里得距离。

思路:分别求出每个人在x方向上和y方向上离其他人距离的总和。计算的时候的技巧就是先排序,第i个人和第i-1个人相差的距离和就是(n-2*i)*(Xi-Xi-1),这个很容易推得。这样就是O(n)的算法了。

代码如下:

<pre name="code" class="cpp">#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>

using namespace std;

#define MAXN 100010
#define INF 1e9+7
#define MODE 1000000

struct pos{
    long long x;
    long long y;
    int ID;
};

pos a[MAXN];

long long dx[MAXN];
long long dy[MAXN];

int cmp1(pos a,pos b)
{
    if(a.x!=b.x)
        return a.x<b.x;
    else
        return a.y<b.y;
}

int cmp2(pos a,pos b)
{
    if(a.y!=b.y)
        return a.y<b.y;
    else
        return a.x<b.x;
}

//int x[MAXN];
//int y[MAXN];
//
//long long solve(int a[],int n)
//{
//    sort(a,a+n);
//    int x;
//    if(n%2==0)
//    {
//        x=n/2;
//    }
//    else
//        x=n/2;
//    long long res=0;
//    for(int i=0;i<n;i++)
//        res+=abs(a[i]-a[x])+abs(a[i]);
//    return res;
//}
int main()
{
    //freopen("in.txt","r",stdin);
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        long long minx=0,miny=0,minn=INF;
        for(int i=0;i<n;i++){
            scanf("%I64d%I64d",&a[i].x,&a[i].y);
            a[i].ID=i;
        }
        sort(a,a+n,cmp1);
        for(int i=0;i<n;i++)
        {
            minx+=abs(a[i].x-a[0].x);
        }
        dx[a[0].ID]=minx;
        for(int x=1;x<n;x++)
        {
            dx[a[x].ID]=dx[a[x-1].ID]-(a[x].x-a[x-1].x)*(n-2*x);
        }

        sort(a,a+n,cmp2);
        for(int i=0;i<n;i++)
        {
            miny+=abs(a[i].y-a[0].y);
        }
        dy[a[0].ID]=miny;
        for(int x=1;x<n;x++)
        {
            dy[a[x].ID]=dy[a[x-1].ID]-(a[x].y-a[x-1].y)*(n-2*x);
        }
        minn=dx[0]+dy[0];
        for(int i=1;i<n;i++)
        {
            minn=min(minn,dx[i]+dy[i]);
        }
        printf("%I64d\n",minn);
    }

}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值