POJ2015 Permutation Code


Description

As the owner of a computer forensics company, you have just been given the following note by a new client: 
I, Albert Charles Montgomery, have just discovered the most amazing cypher for encrypting messages. Let me tell you about it. 

To begin, you will need to decide on a set of symbols, call it S, perhaps with the letters RATE. The size of this set must be a power of 2 and the order of the symbols in S is important. You must note that R is at position 0, A at 1, T at 2, and E at 3. You will also need one permutation P of all those symbols, say TEAR. Finally you will need an integer, call it x. Together, these make up the key. Given a key, you are now ready to convert a plaintext message M of length n (M[0], M[1]... M[n-1]), that has some but not necessarily all of the symbols in S, into a cyphertext string C, also of length n (C[0], C[1],...C[n-1]), that has some but not necessarily all of the symbols in S. 


The encrypting algorithm computes C as follows: 
  1. Calculate an integer d as the remainder after dividing the integer part of (n1.5 + x) by n. This can be expressed more succinctly as d = (int)(n1.5 + x) % n, where "%" is the remainder operator. 
  2. Set C[d] to be the symbol in S whose position is the same as the position of M[d] in P. 
  3. For each j != d in 0..n-1, set C[j] to be the symbol in S whose position is the value obtained by xor-ing the position of M[j] in P with the position of M[(j+1) % n] in S. Note that the bitwise xor operator is "^" in C, C++, and Java.

For example, consider this scenario where S=RATE, P=TEAR, x=102, M=TEETER, and n=6. To compute d, first calculate 6 1.5  + 102 = 116.696938, then take the remainder after dividing by 6. So d = 116 % 6 = 2. The following table shows the steps in filling in the cyphertext C. Note that the order of the steps is not important. 
  0 1 2 3 4 5  
S = R A T E      
P = T E A R      
M = T E E T E R  
               
C = E           M[0] is T, T is at P[0]. M[1] is E, E is at S[3]. C[0] = S[0 xor 3] = S[3]
  E T         M[1] is E, E is at P[1]. M[2] is E, E is at S[3]. C[1] = S[1 xor 3] = S[2]
  E T A       2 is d. M[2] is E, E is at P[1], so C[2] =  S[1]
  E T A E     M[3] is T, T is at P[0]. M[4] is E, E is at S[3]. C[3] = S[0 xor 3] = S[3]
  E T A E A   M[4] is E, E is at P[1]. M[5] is R, R is at S[0]. C[4] = S[1 xor 0] = S[1]
  E T A E A A M[5] is R, R is at P[3]. M[0] is T, T is at S[2]. C[5] = S[3 xor 2] = S[1]

I have included additional examples of encrypted messages at the end of this note for you to experiment with. However, first, I need to tell you about the decryption algorithm. 
Unfortunately, the next page of the note, with the decrypting algorithm, is completely unreadable because it is covered with huge, overlapping, messy ink blots. Given your considerable skill in unravelling puzzles, your task is to write the decoder based on your knowledge of the encoding algorithm.

Input

The input for the decoder consists of one or more sets of {key, encrypted message} pairs. The key is on 3 separate lines. The first line contains the single integer x, 0 < x < 10,000; the second line contains the string S; and the third line contains the string P, which will be a permutation of S. The length of S (and therefore P) will always be one of the following powers of two: 2, 4, 8, 16, or 32. Following the key is a line containing the encrypted message string C, which will contain at least one and at most sixty characters. The strings S, P, and C will not contain whitespace, but may contain printable characters other than letters and digits. The end of the input is a line which contains the single integer 0.

Output

For each input set print the decrypted string on a single line, as shown in the sample output.

Sample Input

102
RATE
TEAR
ETAEAA
32
ABCDEFGHIJKLMNOPQRSTUVWXYZ._!?,;
;ABCDEFGHIJKLMNOPQRSTUVWXYZ._!?,
MOMCUKZ,ZPD
1956
ACEHINT_
ACTN_IHE
CIANCTNAAIECIA_TAI
0

Sample Output

TEETER
HELLO_WORLD
THE_CAT_IN_THE_HAT
 
  
 
  
 
  
 
  
 
  
题目分析:
此题题目意思很难理解但理解之后就很简单就能过掉!
加密算法计算C为如下:
1.计算余数的整数d由n个分割后的整数部分。这可以更简洁地表示为d=(int)(N的1.5次方+ x)%n,其中“%”是求余运算符。
2.集合C[d]在S中的符号的位置是相同的位置的M[d]在P。
3.对于每个j!= D;0.. n-1个,设置C [J]符号在S的位置异或上M[(j +1)%N]与 S相同的位置.注意按位异或运算符“^”在C,C+ +和Java。
例如;
   x=102, S=RATE, P=TEAR, C=ETAEAA,  n=strlen(C)=6;
1.d=pow(6*1.0,1.5)+x)%n;  d=2;
2.因为C[2]=S[1];所以 M[2]=P[1]
3.现在求M[1]
    因为C[1]=S[2];
         M[(1+1)%6]=M[2]=S[3]
    所以 M[1]=P[2^3];  
依次类推求出M;
代码:
 
  
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <queue>
#include <cstdio>
#include <cmath>
#include <string>
#include <stack>
using namespace std;
int main()
{
    int n,x,i,j,k,l1,l2,l3,d,a;
    char s[40],p[40],m[70],c[70];
    while(~scanf("%d",&x)&&x)
    {
        cin>>s>>p>>c;
        l1=strlen(s);
        l3=strlen(c);
        d=((int)pow(l3*1.0,1.5)+x)%l3;//求出d
        memset(m,0,sizeof(m));
        for(i=0; i<l1; i++)
            if(c[d]==s[i])//求出C[d];
                break;
        m[d]=p[i];
        for(i=d-1; (i+l3)%l3!=d; i--)
        {
            if(i<0)
                i=(i+l3)%l3;
            for(j=0; j<l1; j++)//找出c[i]在S中相等的位置j;
                if(c[i]==s[j])
                    break;
            for(k=0; k<l1; k++)//找出m[(i+1)%l3]在S中相等的位置k;
                if(m[(i+1)%l3]==s[k])
                    break;
            a=j^k;
            m[i]=p[a];//求出m[i];
        }
        printf("%s\n",m);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值