poj 3372 Candy Distribution


Description

N children standing in circle who are numbered 1 through N clockwise are waiting their candies. Their teacher distributes the candies by in the following way:

First the teacher gives child No.1 and No.2 a candy each. Then he walks clockwise along the circle, skipping one child (child No.3) and giving the next one (child No.4) a candy. And then he goes on his walk, skipping two children (child No.5 and No.6) and giving the next one (child No.7) a candy. And so on.

Now you have to tell the teacher whether all the children will get at least one candy?

Input

The input consists of several data sets, each containing a positive integer N (2 ≤ N ≤ 1,000,000,000).

Output

For each data set the output should be either "YES" or "NO".

Sample Input

2
3 
4

Sample Output

YES
NO
YES

这是一道找规律题,又规律可以寻找的,自己摸拟几组数据,会发现满足的只有满足2的幂就可以满足。只有判断这个数是否为2的幂即可。


今天无意间看见一个这样一个算式:(n&(n-1))这个表达式能确定一个数是否为2的幂。这非常简单又非常快的表达出来!


代码:

#include<stdio.h>
int main()
{
    int n;
    while(~scanf("%d",&n)){
        if(n>0&&(n&(n-1))==0)
            printf("YES\n");
        else
            printf("NO\n");
    }

return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值