Partition

Description

Define f(n) as the number of ways to perform n in format of the sum of some positive integers. 
For instance, when n=4, 
we have 
  4=1+1+1+1 
  4=1+1+2 
  4=1+2+1 
  4=2+1+1 
  4=1+3 
  4=2+2 
  4=3+1 
  4=4 
totally 8 ways. Actually, we will have f(n)=2  (n-1) after observations. 
Given a pair of integers n and k, your task is to figure out how many times that 
the integer k occurs in such 2  (n-1) ways. 
In the example above, number 1 occurs for 12 times, while number 4 only occurs once. 
 

Input

The first line contains a single integer T(1≤T≤10000), indicating the number of test cases. 
Each test case contains two integers n and k(1≤n,k≤10  9). 
 

Output

Output the required answer modulo 10  9+7 for each test case, one per line.
 

Sample Input

       
       
2 4 2 5 5
 

Sample Output

       
       
5 1
 



自己写几个数会发现一个规律!!
会打出一个表格:
    1        2      3      4        5
1  1       0       0       0        0
2  2       1
3  5       2       1
4  12     5        2     1
5   28    12      5     2      1
 呵呵,发现对角线的数是相同的吧!还有竖着是不是   a[n]=a[n-1]*2+2^(n-2)呢!!
聪明,现在就运用高中的知识就能求出a[n]的通项了。a[n]=(n-3)*2^(n-2);到此以成功
一大半了,接下来就用一个2的快速幂,不然会超时!!
代码:

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <queue>
#include <cstdio>
#include <cmath>
#include <string>
#include <stack>
#include <cctype>
using namespace std;

__int64 exp_mod(__int64 a,__int64 n,__int64 b)
{
__int64 t;
if(n==0) return 1%b;
if(n==1) return a%b;
t=exp_mod(a,n/2,b);
t=t*t%b;
if((n&1)==1) t=t*a%b;
return t;
}

int main()
{
    int t;
    __int64 n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d",&n,&m);
        __int64 temp;
        if(m>n)
            printf("0\n");
        else{
            temp=n-m;

        if(temp==0)
            printf("1\n");

        else if(temp==1)
            printf("2\n");

        else
        {
            __int64 ans;
            ans=(temp+3)*exp_mod(2,temp-2,1000000007)%1000000007;
            printf("%I64d\n",ans);
        }
        }
        
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值