8.23 bzoj1196[HNOI2006]公路修建问题

Description

OI island是一个非常漂亮的岛屿,自开发以来,到这儿来旅游的人很多。然而,由于该岛屿刚刚开发不久,所以那里的交通情况还是很糟糕。所以,OIER Association组织成立了,旨在建立OI island的交通系统。 OI island有n个旅游景点,不妨将它们从1到n标号。现在,OIER Association需要修公路将这些景点连接起来。一条公路连接两个景点。公路有,不妨称它们为一级公路和二级公路。一级公路上的车速快,但是修路的花费要大一些。 OIER Association打算修n-1条公路将这些景点连接起来(使得任意两个景点之间都会有一条路径)。为了保证公路系统的效率, OIER Association希望在这n-1条公路之中,至少有k条(0≤k≤n-1)一级公路。OIER Association也不希望为一条公路花费的钱。所以,他们希望在满足上述条件的情况下,花费最多的一条公路的花费尽可能的少。而你的任务就是,在给定一些可能修建的公路的情况下,选择n-1条公路,满足上面的条件。

Input

第一行有三个数n(1≤n≤10000),k(0≤k≤n-1),m(n-1≤m≤20000),这些数之间用空格分开。 N和k如前所述,m表示有m对景点之间可以修公路。以下的m-1行,每一行有4个正整数a,b,c1,c2 (1≤a,b≤n,a≠b,1≤c2≤c1≤30000)表示在景点a与b 之间可以修公路,如果修一级公路,则需要c1的花费,如果修二级公路,则需要c2的花费。

Output

一个数据,表示花费最大的公路的花费。

Sample Input

10 4 20
3 9 6 3
1 3 4 1
5 3 10 2
8 9 8 7
6 8 8 3
7 1 3 2
4 9 9 5
10 8 9 1
2 6 9 1
6 7 9 8
2 6 2 1
3 8 9 5
3 2 9 6
1 6 10 3
5 6 3 1
2 7 6 1
7 8 6 2
10 9 2 1
7 1 10 2

Sample Output

5

题解:这道题非常简单,就是先二分最大长度,然后用并查集检验答案是否正确即可

tips:bzoj的sort必须要加库algorithm.h否则CE

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <memory.h>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <limits.h>
#include <malloc.h>
#include <algorithm>
#include <ctype.h>
#include <float.h>
using namespace std;

const int maxn=100005;
const int maxm=200005;
int n,m,k,i;
int l,r,mm;
int b[maxn];

struct edge{
    int a,b,c1,c2;
    edge(){a=b=c1=c2=0;}
    edge(int x,int y,int z,int w){
        a=x;b=y;c1=z;c2=w;
    }
    bool operator < (const edge q) const{
        if(c1<q.c1)
            return true;
        if(c1==q.c1)
            return c2<q.c2;
        return false;
    }
} e[maxm];

int find(int x){return x==b[x]?x:find(b[x]);}

void unit(int x,int y){
    int p=find(x);
    int q=find(y);
    if(p!=q)
        b[p]=q;
}

int work(int x){
    int sumk=0;
    int i;
    for(i=1;i<=n;i++)
        b[i]=i;
    i=1;
    while(i<=m){
        if(find(e[i].a)!=find(e[i].b)&&e[i].c2<=x){
            unit(e[i].a,e[i].b);
            if(e[i].c1<=x)
                sumk++;
        }
        i++;
    }
    if(sumk<k)
        return 0;
    for(i=2;i<=n;i++)
        if(find(i-1)!=find(i))
            return 0;
    return 1;
}

int main(){
    scanf("%d %d %d",&n,&k,&m);
    m--;
    for(i=1;i<=m;i++)
        scanf("%d %d %d %d",&e[i].a,&e[i].b,&e[i].c1,&e[i].c2);
    //for(i=1;i<=m;i++)
    //    printf("%d:%d %d %d %d\n",i,e[i].a,e[i].b,e[i].c1,e[i].c2);
    sort(e+1,e+1+m);
    //for(i=1;i<=m;i++)
    //    printf("%d:%d %d %d %d\n",i,e[i].a,e[i].b,e[i].c1,e[i].c2);
    l=1;
    r=30000;
    while(l<r-1){
        mm=(l+r)/2;
        if(work(mm))
            r=mm;
        else
            l=mm;
    }
    work(80);
    //printf("%d\n",work(5));
    printf("%d\n",r);
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值