二叉排序树的创建

题目描述:

    输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入:

    输入第一行包括一个整数n(1<=n<=100)。
    接下来的一行包括n个整数。

输出:

    可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。
    每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入:
5
1 6 5 9 8
样例输出:
1 6 5 9 8 
1 5 6 8 9 
5 8 9 6 1 
提示:

输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。

#include<stdio.h>

struct Node 
{
	Node * lChild;
	Node * rChild;
	int data;
}tree[101];  //静态数组分配内存空间, 可以不用考虑动态内存的申请和释放

int alloc;
Node *createNode()
{
	tree[alloc].lChild=tree[alloc].rChild=NULL;
	return &tree[alloc++];
}
Node* insert(Node *T,int data) //递归插入数据,每次都要返回根节点
{
	if(T==NULL)
	{
		T=createNode();
		T->data=data;
		return T;
	}
	else if(T->data>data)
		T->lChild=insert(T->lChild,data);
	else if(T->data<data)
		T->rChild=insert(T->rChild,data);
	return T;
}

void pre_order(Node *root)
{
	if(root)
	{
		printf("%d ",root->data);
		pre_order(root->lChild);
		pre_order(root->rChild);
	}
}

void in_order(Node *root)
{
		if(root->lChild!=NULL)
			in_order(root->lChild);

		printf("%d ",root->data);

		if(root->rChild!=NULL)
			in_order(root->rChild);
}

void post_order(Node *root)
{
		if(root->lChild!=NULL)
			post_order(root->lChild);
		if(root->rChild!=NULL)
			post_order(root->rChild);
		printf("%d ",root->data);
}

int main()
{
	int n,i,data;
	while(scanf("%d",&n)!=EOF)
	{
		Node *T=NULL;
		alloc=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&data);
			T=insert(T,data);
		}
		pre_order(T); 
		printf("\n");
		in_order(T);
		printf("\n");
		post_order(T);
		printf("\n");
	}
	

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值