日期类-求星期几

题目描述:

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出:

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入:
9 October 2001
14 October 2001
样例输出:
Tuesday
Sunday
提示:

Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October, November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday


分析:

1. 今天星期几

2. 今天和给定日期相隔的天数

#include<stdio.h>
#include<string.h>

//每个月平年和润年的天数
int dayOfmonth[13][2]={
	{0,0},
	{31,31}, //1
	{28,29}, //2
	{31,31}, //3
	{30,30}, //4
	{31,31}, //5
	{30,30}, //6
	{31,31}, //7
	{31,31}, //8
	{30,30}, //9
	{31,31}, //10
	{30,30}, //11
	{31,31}, //12
};

char months[13][20]={
	"zero","January", "February", "March"," April", "May", "June", "July", "August", "September", "October", "November", "December"
};
char weeks[8][20]={"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday",""};
int buffer[3001][13][32]; //每个日期到原点日期的天数  x,y,z代表年、月、日

int isLeapYear(int year)
{
	if(  (year%4==0 && year%100!=0) || year%400==0  )
		return true;
	return false;
}
struct Date
{
	int year;
	int month;
	int day;
	void nextDay()
	{
		day++;
		if(day>dayOfmonth[month][isLeapYear(year)])
		{
			day=1;
			month++;
			if(month>12)
			{
				month=1;
				year++;
			}
		}
	}
};

int main()
{
	Date d;
	d.year=0;
	d.month=1;
	d.day=1;
	int cnt=0;
	while(d.year<=3000)
	{
		buffer[d.year][d.month][d.day]=cnt;
		d.nextDay();
		cnt++;
	}

	int day,year;
	char month[20];
	while(scanf("%d %s %d",&day,&month,&year)!=EOF)
	{
		int i;
		for(i=1;i<=12;i++)
			if(strcmp(month,months[i])==0)
				break;
		int d1=buffer[year][i][day];
		int d2=buffer[2014][8][17]; //周七
		int d3=(d1-d2)%7;
		if(d3<0)//余数可能为负数
			d3=d3+7;
		printf("%s\n",weeks[d3]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值