UVA 10420 - List of Conquests

题目链接:UVA 10420 - List of Conquests


Problem B
List of Conquests
Input: 
standard input
Output: 
standard output
Time Limit: 
2 seconds

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna

Sample Output

England 1

Spain 2

题意


统计每个国家的美女数目 (统计这个国家的名字在输入数据中出现的次数)

分析


统计第一个单词出现的次数,后面的字符全部省略,因为没有重复的女人的名字的情况,注意字符串处理问题。最后按字典序排列,只要用sort函数排序即可。

代码


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct country
{
    char name[110];
    int num;
}CT[2020];

int cnt;
int Find(char str[])
{
    for(int i = 0; i < cnt; i++)
        if(strcmp(str, CT[i].name)==0)
            return i;
    return -1;
}
bool cmp(country a, country b)
{
    return strcmp(a.name, b.name) < 0;
}
int main()
{
    int n;
    char str[110],sss[110];
    scanf("%d", &n);
    gets(sss);
    cnt = 0;
    while(n--)
    {
        scanf("%s", str);
        gets(sss);
        int x = Find(str);
        if(x != -1)
            CT[x].num++;
        else
        {
            strcpy(CT[cnt].name, str);
            CT[cnt].num = 1;
            cnt++;
        }
    }
    sort(CT, CT+cnt, cmp);
    for(int i = 0; i < cnt; i++)
        printf("%s %d\n", CT[i].name, CT[i].num);

    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值