UVA 120 - Stacks of Flapjacks

题目链接:UVA 120 - Stacks of Flapjacks

 Stacks of Flapjacks 

Background

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

The Problem

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in a stack have different diameters.

Sorting a stack is done by a sequence of pancake ``flips''. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

         8           7           2
         4           6           5
         6           4           8
         7           8           4
         5           5           6
         2           2           7
The stack on the left can be transformed to the stack in the middle via  flip(3) . The middle stack can be transformed into the right stack via the command  flip(1) .

The Input

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

The Output

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

Sample Input

1 2 3 4 5
5 4 3 2 1
5 1 2 3 4

Sample Output

1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

题意


给你一叠薄煎饼,请你写一个程序来指出要如何安排才能使这些薄煎饼由上到下依薄煎饼的半径由小到大排好。 所有的薄煎饼半径均不相同。 要把薄煎饼排好序需要对这些薄煎饼做翻面(flip)的动作。 方法是以一抹刀插入一叠薄煎饼中,然后做翻面的动作(也就是说在抹刀上面的薄煎饼经翻 面后,会依相反的次序排列)。 若一叠共有n个薄煎饼,我们定义最底下的薄煎饼的位置为1,最上面的薄煎饼位置为n。 当抹刀插入位置为k时,代表从位置k到 位置n的薄煎饼要做翻面的动作。 一开始时,这叠薄煎饼随意堆放,并以半径大小来表示。 例如:以下3叠薄煎饼(最左边那一叠8是最上面一个薄煎饼的半径)

        8           7           2
        4           6           5
        6           4           8
        7           8           4
        5           5           6
        2           2           7

对最左边那叠薄煎饼,如果我们把抹刀插在位置3(就是半径为7的那块薄煎饼的下面)的地方做翻面, 就会得到中间那叠,如果我们再把抹刀插在位置 1(就是半径为2的那块薄煎饼的下面)的地方做翻面, 就会得到最右边那叠。

分析


这道题目有点知其然,不知其所以然了。用了一点贪心的思想,这应该也是一种排序算法,有点选择排序的意思。选择排序是把无序区中的最小值或最大值与无序区中的首元素交换。这道题也是一个道理,不仅仅是做交换操作,而且只能通过翻转的规则来进行交换,因而就有必要把要找的数先翻转到第一层,然后再翻转到它应该在的那一层。至于为什么次数最少,我也说不上来。

代码


#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int a[33], b[33], n;
int Find(int x)
{
    for(int i = 1; i <= n; i++)
        if(x == a[i])
            return i;
    return -1;
}

void swap2(int x)
{
    int c[33];
    for(int i = 1; i <= x; i++)
        c[i] = a[x-i+1];
    for(int i = 1; i <= x; i++)
        a[i] = c[i];
}
int main()
{
    //freopen("120in.txt", "r", stdin);
    //freopen("120out.txt", "w", stdout);
    char ch;
    n = 1;
    int dia;
    while(scanf("%d%c", &dia, &ch) != EOF)
    {
        a[n] = b[n] = dia;
        n++;
        if(ch == '\n')
        {
            n--;
            sort(b+1, b+n+1);
            for(int i = 1; i < n; i++)
                printf("%d ", a[i]);
            printf("%d\n", a[n]);
            for(int i = n; i >= 1; i--)
            {
                int x = Find(b[i]);
                if(x == i) continue;
                if(x != 1)
                {
                    swap2(x);
                    printf("%d ", n-x+1);
                }
                swap2(i);
                printf("%d ", n-i+1);
            }
            printf("0\n");
            n = 1;
        }
    }
    return 0;
}





  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值