HDU 1242 Rescue营救 BFS算法

2 篇文章 0 订阅

题目链接:HDU 1242 Rescue营救

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16524    Accepted Submission(s): 5997


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

题意:

Angel被关在一个监狱中,监狱可有N*M的矩阵表示,每个方格中可能有墙壁(#)、道路(.)、警卫(x)、Angel(a)和Angel的朋友(r)。Angel的朋友想到达Angel处,要么走道路,需要1的时间,要么走到警卫的格子,还需要多1的时间杀死警卫才能通行。现在需要求到达Angel处的最短时间。

分析:

求最短时间一般都用BFS搜索,但是这道题条件较多,需要酌情考虑。并不是步数最少就最好,因为杀死警卫还需要额外的时间。可以新建一个结构体point,表示当前位置和已经使用的时间。再申请一个数组mintime[][],表示走到某一格的最短时间。将可行的当前位置压入队列并持续更新mintime数组。找到Angel所在位置的mintime。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

#define INF 0xffffff
char mp[202][202];
int n, m, mintime[202][202];
int dir[4][2] = {{-1, 0},{0, 1},{1, 0},{0, -1}};

struct point
{
    int x, y, time;
};
void bfs(point s)
{
    queue<point> q;
    q.push(s);
    while(!q.empty())
    {
        point cp = q.front();
        q.pop();
        for(int i = 0; i < 4; i++)
        {
            int tx = cp.x + dir[i][0];
            int ty = cp.y + dir[i][1];
            if(tx >= 1 && tx <= n && ty >= 1 && ty <= m && mp[tx][ty] != '#')
            {
                point t;
                t.x = tx;
                t.y = ty;
                t.time = cp.time+1;
                if(mp[tx][ty] == 'x')
                    t.time++;
                if(t.time < mintime[tx][ty])
                {
                    mintime[tx][ty] = t.time;
                    q.push(t);
                }
            }
        }
    }
}
int main()
{
    char c;
    int ax, ay;
    point st;
    while(~scanf("%d%d", &n, &m))
    {
        scanf("%c", &c);
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= m; j++)
            {
                scanf("%c", &mp[i][j]);
                mintime[i][j] = INF;
                if(mp[i][j] == 'a')
                {
                    ax = i;
                    ay = j;
                }
                else if(mp[i][j] == 'r')
                {
                    st.x = i;
                    st.y = j;
                    st.time = 0;
                }
            }
            scanf("%c", &c);
        }
        mintime[st.x][st.y] = 0;
        bfs(st);
        if(mintime[ax][ay] < INF)
            printf("%d\n", mintime[ax][ay]);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}






  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值