POJ 3176 Cow Bowling 保龄球 数塔问题 DP

17 篇文章 0 订阅
12 篇文章 0 订阅

题目链接:POJ 3176 Cow Bowling

Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14044 Accepted: 9310

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

Source


题意:

从数塔的第一层走到最底层,但只能沿对角线走,求路径上的数的和的最大值。

分析:

从最底层向上考虑,路径上的和的大小取决于直接取决于下面两个数的大小。因而采用自顶向上方法,逐步向上走,走到最顶层,每次都选择最大的和,这样最后的结果就保存在了最顶层。

状态转移方程:dp[i][j] = max(dp[i+1][j], dp[i+1][j+1])+A[i][j];

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAX_N = 400;
int dp[MAX_N][MAX_N];
int N, A[MAX_N][MAX_N];
void solve() {
    memset(dp, 0, sizeof(dp));
    for(int i = 1; i <= N; i++) dp[N][i] = A[N][i];
    for(int i = N-1; i >= 1; i--)
        for(int j = 1; j <= i; j++)
            dp[i][j] = A[i][j]+max(dp[i+1][j], dp[i+1][j+1]);
    printf("%d\n", dp[1][1]);
}
int main() {
    while(~scanf("%d", &N)) {
        for(int i = 1; i <= N; i++) 
            for(int j = 1; j <= i; j++)
                scanf("%d", &A[i][j]);
        solve();
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值