hdu1002

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

#include<stdio.h>
#include<string.h>
void daozhi(char *a)       //把字符串倒置一下,再相加,不倒置最前面进位不了。
{
	int i,l=strlen(a);
	char s;
	for(i=0;i<l/2;i++)
	{
		s=a[i];a[i]=a[l-1-i];a[l-1-i]=s;
	}
}
void jia(char *a,char *b)    //大数的相加
{
	int len1=strlen(a),len2=strlen(b);
	for(int i=0;i<len1;i++)
	{
		if(i<len2)
		a[i]+=b[i]-48;
		if(a[i]>'9')         //大于9就向前进一位
		{
			if(a[i+1]!='\0')a[i+1]++;
			else a[i+1]='1';
			a[i]=(a[i]-48)%10+48;
		}
	}
	if(a[len1]=='1')a[len1+1]='\0';  //防止最后进位时不能进位
	else a[len1]='\0';
}
int main()
{
	char a[1111],b[1111],s;
	int i,j,q,len1,len2,t;
	while(~scanf("%d",&t))
	{
		for(q=1;q<=t;q++)
		{
			scanf("%s%s",a,b);
			len1=strlen(a);
			len2=strlen(b);
			printf("Case %d:\n",q);
			printf("%s + %s = ",a,b);
			daozhi(a);daozhi(b);
			if(len1>=len2)
			{
				jia(a,b);
			    daozhi(a);
		       	printf("%s\n",a);
			}
		    else 
			{
			   jia(b,a);
			   daozhi(b);
			   printf("%s\n",b);
			}
			if(q<t)      //数据之间的空行
				printf("\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值