COJ 1239集合set的简单应用

Input
 There are only one case, including two lines, the fist line only contain one integer N, stands for the amount of raom digits . The second line contains N integers, stand for random digits (students number).

Output
 There are 2 lines here, too. The first line contains one integer M. M means the different random digits’ amount. The second line contains M Integer separated by space, stand for the different integers in order.

Sample Input
10
20 40 32 67 40 20 89 300 400 15


Sample Output
8
15 20 32 40 67 89 300 400

Hint
20 and 40 only can left one。
<set>

思路:set默认的是升序,若要使其降序,则写个重载函数,重载函数我还不会写呢奋斗
#include<iostream>
#include<set>
using namespace std;
int main()
{
    int i,j=0,n,a[105];
    cin>>n;
    for(i=0;i<n;i++)
        cin>>a[i];
    set<int>b;
    b.insert(a,a+n);
    set<int>::iterator it;
    for(it=b.begin();it!=b.end();it++)
        j++;
    cout<<j<<endl;
    for(it=b.begin();it!=b.end();it++)
        cout<<*it<<' ';
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值