POJ 2352数状数组(一维)

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27677 Accepted: 12099

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

思路:刚开始没明白题目说的是什么,有点模糊,看了别人的解释才明白是什么意思……题意快速理解:给出n个平面二维坐标,对于每个坐标,如果这个坐标跟(0,0)形成的矩形内包含的点数为 k (包含边界,但不包含坐标本身),那么这个坐标就是 level k(因为坐标不同,包含的点数有相同的,所以level k当然值就不一样)。输出level 0 - n-1的点数分别是多少。例如:

5
1 1
5 1
7 1
3 3
5 5
在草稿上画个坐标图就容易理解了:包含0个点的坐标有(1,1)共1个点,包含1个点的坐标有(5,1)和(3,3)共2个点,包含2个点的坐标有(7,1)共1个点…………等等……

所以输出才为:

1
2
1
1
0
明白之后就理解数状数组怎么解了…………

#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <ctime>
#include <cstdlib>
#include <stack>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#define M 33050
int n,level[M]={0},c[M]={0};
using namespace std;
int lowbit(int x)
{
    return x&(-x);
}
void updata(int x)
{
    for(int i=x;i<=32004;i+=lowbit(i))
        c[i]++; //单点更新只加1,因为发现一点就更新滴!!!
}
int sum(int x)
{
    int i,ans = 0 ;
    for(i=x ; i>=1; i-=lowbit(i))
        ans += c[i];
    return ans ;
}
int main()
{
    int i,x,y;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        x++;  //因为数状数组从1开始,而横坐标可能为0,所以右移没有影响相对位置的
        level[sum(x)]++;//sum(x)为包含多少个点,而level[sum(x)]指包含这些点的点总共有多少个点
        updata(x); //因为不包含本身,所以在统计后才会更新结点
    }
    for(i=0;i<n;i++)
        printf("%d\n",level[i]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值