hdu——2002——sort

Problem Description
给你n个整数,请按从大到小的顺序输出其中前m大的数。

Input
每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。

Output
对每组测试数据按从大到小的顺序输出前m大的数。
 
Sample Input
5 3
3 -35 92 213 -644
 
Sample Output

213 92 3

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>

using namespace std;
const int M=1000005;
const int N=500000;

int  hash[M];

int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
	    memset(hash,0,sizeof(hash));
	    int temp;
		for(int i=0;i<n;i++)
		{
			scanf("%d",&temp);
			hash[temp+N]=1;
		}
		int count=0;
		for(int i=M;i>=0;i--)
		{
			if(hash[i]==1)
			{
				count++;
				if(count==m)
				{
					printf("%d\n",i-N);
					break;
				}
				else
				printf("%d ",i-N);		
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值