poj——2255——Tree Recovery

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

题意:输入前序遍历和中序遍历,输出后序遍历

先找到根结点,一定是前序遍历的第一个,是中序遍历的中间一个,也是后序遍历的最后一个,然后根据中序遍历,根节点之前的一定是在左子树中,根节点之后的一定是在右子树中,然后分别递归左子树和右子树

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
char pre[100];//先序遍历
char in[100];//中序遍历
char post[100];//后序遍历
int len;//节点个数
void solve(int p1,int p2,int m1,int m2)
{
    if(p1>p2)
    return;
    int i;
    for(i=m1;i<=m2;i++)
    {
        if(in[i]==pre[p1])
        break;
    }
    post[--len]=pre[p1];
    if(p1==p2)
    return;
    solve(p1+i-m1+1,p2,i+1,m2);
    solve(p1+1,p1+i-m1,m1,i-1);
}
int main()
{
    while(cin>>pre>>in)
    {
        memset(post,0,sizeof(post));
        len=strlen(pre);
        solve(0,len-1,0,len-1);
        cout<<post<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值