Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
#include<stdio.h>
int n,m,num;
char map[100][100];
int d[4][2]={0,1,1,0,-1,0,0,-1};
typedef struct stu{
int a,b;
}tree;
tree p[10000];
void bfs(tree start)
{
tree in,next;
int top,end,i;
top=end=0;
p[top]=start;
while(end<=top)
{
in=p[end];
end=(end+1)%10000;
for(i=0;i<4;i++)
{
next.a=in.a+d[i][0];
next.b=in.b+d[i][1];
if(next.a>=0&&next.b>=0&&next.a<m&&next.b<n&&map[next.a][next.b]=='.')
{
map[next.a][next.b]='#';
num++;
top=(top+1)%10000;
p[top]=next;
}
}
}
}
int main()
{
int i,j,x,y;
tree start;
while(scanf("%d%d",&n,&m),m||n)
{
num=1;
getchar();
for(i=0;i<m;i++)
{
gets(map[i]);
for(j=0;j<n;j++)
if(map[i][j]=='@')
{
x=i;y=j;
}
}
start.a=x;start.b=y;
map[x][y]='#';
bfs(start);
printf("%d\n",num);
}
return 0;
}