hdu——An Easy Problem

As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.

For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".
 

Input
One integer per line, which is I (1 <= I <= 1000000).

A line containing a number "0" terminates input, and this line need not be processed.
 

Output
One integer per line, which is J.
 

Sample Input
  
  
1 2 3 4 78 0
 
Sample Output
  
  
2 4 5 8 83
 
 #include <stdio.h>
 int main()
{
     int n,x;
    while(scanf("%d",&n),n)
    {
         x=n&-n;
         printf("%d\n",n+x+(n^n+x)/x/4);
     }
 }
另一种方法:
#include <iostream>
using namespace std;
const int MAX_BIT=32;
int CountOne(int input)
{
    int cnt=0;
    for (int i=0; i<MAX_BIT; i++)
    {
        if (input>>i&1)//右移i位,比较与1的大小,如果相等则++;
        {
            cnt++;
        }

    }
    return cnt;

}
int main()
{
    int input;
    while (cin>>input)
    {
        if(input==0)
        break;
        for (int ii=input+1;; ii++)
        {
            if(CountOne(ii)==CountOne(input))
            {
                cout<<ii<<endl;
                break;
            }
        }
    }
    return 1;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值