hdu1312(Red and Black)

点击打开杭电1312

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
import java.util.Scanner;


public class P1312 {
	public static int n,m,count;
	public static int[][] dir={{1, 0}, {0, -1}, { -1, 0}, {0, 1}};//朝四个方向遍历
	public static char[][] map=new char[30][30];//地图
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			count=0;
			m=sc.nextInt();
			n=sc.nextInt();
			if(m==0&&n==0){
				break;
			}
			for(int i=0;i<n;i++){
				String s=sc.next();
				map[i]=s.toCharArray();
			}
			boolean sign=false;
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){
					if(map[i][j]=='@'){//先找到@这点,然后将其作为起点朝四个方向递归遍历
						sign=true;//优化,因为只有一个@,所以只要进来,就不需要找循环找@了
						DFS(i,j);
					}
					if(sign){//优化
						break;
					}
				}
			}
			System.out.println(count+1);
		}
	}
	private static void DFS(int a, int b) {
		int x,y;
		for(int i=0;i<4;i++){
			x=a+dir[i][0];
			y=b+dir[i][1];
			if(x>=0&&y>=0&&x<n&&y<m&&map[x][y]=='.'){
				count++;
				map[x][y]='#';//直接把找到的'.' 变为#,这样就避免visit标记地图了
				DFS(x,y);
			}
		}
	}

}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值