POJ 2236

Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 14631 Accepted: 6157

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS


题意 N台坏电脑 如果碰到‘O’就修复该台电脑A,如果碰到‘S’就查询 A B 是否能够直接交流,而且交流的距离不得超过D,所以题目转化为判断任意两点是否连通的问题,
而且初始化的情况是所有的电脑不连通,然后一旦修复好了电脑,而且这两台电脑的距离小于D,就把这两台电脑加入集合内。把这些预处理完之后,再进行判断二者是否联通
即可,简单并查集的应用吧。还有这次看到让跑10S怕数据过大所以乖乖的用scanf和printf了o(╯□╰)o
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;

struct node{

int  x;
int  y;

}a[1005];
int pre[1005];
int r[1005];
int n,d;
int  dis(node a,node b)
{
    return ((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
void init()
{
    int i;
    for(i=1;i<=n;i++)
    {
        pre[i]=i;

    }
}

int find(int x)
{
    if(x==pre[x])
        return pre[x];
    pre[x]=find(pre[x]);
    return pre[x];
}

void join(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)

        pre[x]=y;
}
int main()
{

    scanf("%d%d",&n,&d);
    int x,y;
    char s[10];
    for(int i=1;i<=n;i++)
        scanf("%d%d",&a[i].x,&a[i].y);
        init();

    memset(r,0,sizeof(r));
    while(scanf("%s",s)!=EOF)
    {
        if(s[0]=='O')
        {
            scanf("%d",&x);
            r[x]=1;
            for(int i=1;i<=n;i++)
            {
                if(dis(a[i],a[x])<=d*d&&r[i])
                    join(i,x);//只要距离小于D,而且当前的I点被访问,那么就让I与进入的X联通。
            }

        }
        else
        {
            scanf("%d%d",&x,&y);
            if(find(x)!=find(y))
                printf("FAIL\n");
            else
                printf("SUCCESS\n");
        }
    }


    return 0;


}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值