CCNU第五周数学练习的一道水题

E - Semi-prime H-numbers
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

题目意思就是诸如4N+1的数我们把它叫做H-NUMBER数 然后我们现在要来找一个范围内的H-semi-primes数量有多少 而H-semi-primes
这个数呢就是它能且只能由两个H-PRIMES数相乘得到(由多组H-PRIMES数相乘得到没有关系 例如441=21*21=9*49但是它也属于H-semi-primes范畴),
而H-PRIMES数就是只能由1和H-NUMBER数相乘得到的数要注意题目中给的一个条件The H-numbers are closed under multiplication.
说明了这个乘法运算是闭包的也就是说(4*N+1)*(4*M+1)=4*K+1 其中N M K均为大于等于1的正整数所以做这道题我们只需要对满足条件的
数进行暴力的筛选好了,然后全部筛选出来后再来统计下满足条件的个数就可以了。很简单。。没有数论的知识在里面,但是我不知道
如果这道题数字再继续变大的的话暴力筛选会不会被TLE下面贴上我的代码。。。
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 10000001

int H[MAXN+1];

void choose()
{
    int i,j;
    memset(H,0,sizeof(H));
    for(i=5;i<=MAXN;i+=4)
    {
        for(j=5;j<=MAXN;j+=4)
        {
            if(i*j>MAXN)break;
            if(H[i]==0&&H[j]==0)

                H[i*j]=1;


            else
                H[i*j]=-1;
        }
    }



int count=0;

for(i=1;i<=MAXN;i++)
    {
        if(H[i]==1)
        count++;
        H[i]=count;
    }

}


int main()
{
    int h;
    choose();
    while(scanf("%d",&h)!=EOF)
    {
        if(h==0)
            return 0;
        cout<<h<<" "<<H[h]<<endl;
    }




    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值